[bug#76326,1/2] gnu: gpick: Improve the package style.

Message ID 818b72d701f2bd4ed0349e6d7579e0e59d436029.1739695296.git.poptsov.artyom@gmail.com
State New
Headers
Series gnu: gpick: Update to 0.3-1.365f605. |

Commit Message

Artyom V. Poptsov Feb. 16, 2025, 8:45 a.m. UTC
  * gnu/packages/image.scm (gpick): Improve the package style.
[native-inputs, inputs]: Remove input labels.
[arguments]: Use GEXPs.

Change-Id: I7917381255ab5cd129e6c6133246579fb071a03f
---
 gnu/packages/image.scm | 50 +++++++++++++++++++-----------------------
 1 file changed, 22 insertions(+), 28 deletions(-)
  

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 99face4546..282b6582e8 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2044,36 +2044,30 @@  (define-public gpick
   (package
     (name "gpick")
     (version "0.2.6")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/thezbyg/gpick")
-                    (commit (string-append name "-" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0nl89gca5nmbyycv5rl5bm6k7facapdk4pab9pl949aa3cjw9bk7"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/thezbyg/gpick")
+             (commit (string-append name "-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0nl89gca5nmbyycv5rl5bm6k7facapdk4pab9pl949aa3cjw9bk7"))))
     (build-system scons-build-system)
-    (native-inputs
-     `(("boost" ,boost)
-       ("gettext" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)
-       ("ragel" ,ragel)))
-    (inputs
-     `(("expat" ,expat)
-       ("gtk2" ,gtk+-2)
-       ("lua" ,lua-5.2)))
+    (native-inputs (list boost gettext-minimal pkg-config ragel))
+    (inputs (list expat gtk+-2 lua-5.2))
     (arguments
-     `(#:tests? #f
-       #:scons ,scons-python2
-       #:scons-flags (list (string-append "DESTDIR=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'fix-lua-reference
-           (lambda _
-             (substitute* "SConscript"
-               (("lua5.2") "lua-5.2"))
-             #t)))))
+     (list
+      #:tests? #f
+      #:scons scons-python2
+      #:scons-flags #~(list (string-append "DESTDIR=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'build 'fix-lua-reference
+            (lambda _
+              (substitute* "SConscript"
+                (("lua5.2")
+                 "lua-5.2")))))))
     (home-page "http://www.gpick.org/")
     (synopsis "Color picker")
     (description "Gpick is an advanced color picker and palette editing tool.")