[bug#75470,gnome-team,17/59] gnu: Add msgraph.

Message ID 81424be3f29eaf75fc0d671ee12c88caaf5333ed.1736458798.git.liliana.prikler@gmail.com
State New
Headers
Series To 46.7 and beyond |

Commit Message

Liliana Marie Prikler Jan. 9, 2025, 9:38 p.m. UTC
  * gnu/packages/gnome.scm (msgraph): New variable.
---
 gnu/packages/gnome.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6b4890c51d..fec4fb235f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7137,6 +7137,26 @@  (define-public libgudev
 part of udev-extras, then udev, then systemd.  It's now a project on its own.")
     (license license:lgpl2.1+)))
 
+(define-public msgraph
+  (package
+    (name "msgraph")
+    (version "0.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/msgraph/"
+                                  (version-major+minor version) "/"
+                                  "msgraph-" version ".tar.xz"))
+              (sha256
+               (base32 "1c6xkxx2c1jqhy56pfbsmnk418n1rm2fgqyrgi3hf2kzrc0fhhpd"))))
+    (build-system meson-build-system)
+    (native-inputs (list gi-docgen gobject-introspection pkg-config uhttpmock))
+    (inputs (list gnome-online-accounts json-glib libsoup rest))
+    (home-page "https://gnome.pages.gitlab.gnome.org/msgraph/")
+    (synopsis "GLib library for accessing MS Graph APIs")
+    (description "This package provides a GLib-based library for accessing
+MS Graph APIs.")
+    (license license:lgpl3+)))
+
 (define-public gvfs
   (package
     (name "gvfs")