diff mbox series

[bug#48066] gnu: emacs-hyperbole: Install images and help files.

Message ID 812b1b746c1bf8eda7e2561a08a0f68a1b4fc5ce.1619542661.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48066] gnu: emacs-hyperbole: Install images and help files. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 27, 2021, 4:58 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-hyperbole)[arguments]: Include help file
and install images for the manual.
---
 gnu/packages/emacs-xyz.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)


base-commit: e009b8d7126531a2983701413c5b97e620e495e4

Comments

Nicolas Goaziou April 28, 2021, 10:33 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-hyperbole)[arguments]: Include help file
> and install images for the manual.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a46b7e8ae0..8e76f151a5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -359,6 +359,7 @@  server}.  The main advantage compared to @code{vc-hg} is speed.")
      `(#:include '("DEMO"
                    "DEMO-ROLO.otl"
                    "HY-ABOUT"
+                   "man/hkey-help.txt"
                    "\\.el$"
                    "\\.info$"
                    "\\.kotl$")
@@ -373,8 +374,15 @@  server}.  The main advantage compared to @code{vc-hg} is speed.")
                 (string-append (assoc-ref inputs "inetutils")
                                "/bin/dnsdomainname")))
              (substitute* "hyperbole.el"
-               (("\\(hyperb:check-dir-user\\)") ""))
-             #t)))))
+               (("\\(hyperb:check-dir-user\\)") ""))))
+         (add-after 'install 'install-images
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (for-each (lambda (file)
+                           (install-file
+                            file
+                            (string-append out "/share/info/im")))
+                         (find-files "man/im" "\\.png$"))))))))
     (inputs
      `(("inetutils" ,inetutils)))
     (home-page "https://www.gnu.org/software/hyperbole/")