diff mbox series

[bug#39405] gnu: Add fntsample.

Message ID 8114612996cb93db8f0345b84c3ffd794513f8bd.camel@gnu.org
State Accepted
Headers show
Series [bug#39405] gnu: Add fntsample. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Roel Janssen Feb. 7, 2020, 3:35 p.m. UTC
On Tue, 2020-02-04 at 19:39 -0500, Leo Famulari wrote:
> On Mon, Feb 03, 2020 at 12:45:44PM +0100, Roel Janssen wrote:
> > Dear Guix,
> > 
> > I'd like to add "fntsample".  The following two patches do that.
> > 
> > Kind regards,
> > Roel Janssen
> > 
> > From 55ee95f843424cb9f65e4ff3514739b6238a9e14 Mon Sep 17 00:00:00
> > 2001
> > From: Roel Janssen <roel@gnu.org>
> > Date: Mon, 3 Feb 2020 12:28:18 +0100
> > Subject: [PATCH 1/2] gnu: Add perl-pdf-api2.
> > 
> > * gnu/packages/perl.scm (perl-pdf-api2): New variable.
> 
> LGTM, thanks!
> 
> > From 17df554661c71e8724bf3e241021345b9b9cefef Mon Sep 17 00:00:00
> > 2001
> > From: Roel Janssen <roel@gnu.org>
> > Date: Mon, 3 Feb 2020 12:29:33 +0100
> > Subject: [PATCH 2/2] gnu: Add fntsample.
> > 
> > * gnu/packages/fontutils.scm (fntsample): New variable.
> > +           (uri "http://unicode.org/Public/UNIDATA/Blocks.txt")
> 
> Can it go over HTTPS?

It seems so!  I updated the patch(es) and attached them again.

Thanks!

Kind regards,
Roel Janssen

Comments

Leo Famulari Feb. 7, 2020, 11:16 p.m. UTC | #1
> It seems so!  I updated the patch(es) and attached them again.

LGTM, please push!
Roel Janssen March 4, 2020, 8:13 a.m. UTC | #2
On Fri, 2020-02-07 at 18:16 -0500, Leo Famulari wrote:
> > It seems so!  I updated the patch(es) and attached them again.
> 
> LGTM, please push!
> 

Sorry for the long delay.  I just pushed these patches.

Kind regards,
Roel Janssen
diff mbox series

Patch

From b88d7d217595050aad6b74a0b4a8394f7a3213ce Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Mon, 3 Feb 2020 12:28:18 +0100
Subject: [PATCH 1/2] gnu: Add perl-pdf-api2.

* gnu/packages/perl.scm (perl-pdf-api2): New variable.
---
 gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9fc3493a5d..c226f7a996 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7226,6 +7226,30 @@  file names.")
 with file paths.")
     (license asl2.0)))
 
+(define-public perl-pdf-api2
+  (package
+    (name "perl-pdf-api2")
+    (version "2.036")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/S/SS/SSIMMS/PDF-API2-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0x0pa75wpb87pcshl92y5nh8pzikjp46ljlr2pqvdgpqzvll8107"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-exception" ,perl-test-exception)
+       ("perl-test-memory-cycle" ,perl-test-memory-cycle)))
+    (propagated-inputs
+     `(("perl-font-ttf" ,perl-font-ttf)))
+    (home-page "https://metacpan.org/release/PDF-API2")
+    (synopsis "Facilitates the creation and modification of PDF files")
+    (description "This Perl module facilitates the creation and modification
+of PDF files.")
+    (license lgpl2.1)))
+
 (define-public perl-perlio-utf8_strict
   (package
     (name "perl-perlio-utf8-strict")
-- 
2.17.1