diff mbox series

[bug#66814,gnome-team,v5,3/3] gnu: orca: Update to 44.2.

Message ID 80f3e38d7ff1c028044dbdf510318bd245fcae59.1700116481.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#66814,gnome-team,v5,1/3] gnu: at-spi2-core: Update to 2.48.4. | expand

Commit Message

Vivien Kraus Nov. 14, 2023, 4:08 p.m. UTC
* gnu/packages/gnome.scm (orca): Update to 44.2.
[#:phases]<qualify-programs>: Also expand pgrep.
[inputs]: Add procps. Replace at-spi2-atk with at-spi2-core.

Change-Id: I05fdab970909edda44ca9957d2ad721f62e6bfec
---
 gnu/packages/gnome.scm | 21 +++++++++++++++------
 1 file changed, 15 insertions(+), 6 deletions(-)

Comments

Liliana Marie Prikler Nov. 19, 2023, 8:55 a.m. UTC | #1
Am Dienstag, dem 14.11.2023 um 17:08 +0100 schrieb Vivien Kraus:
> * gnu/packages/gnome.scm (orca): Update to 44.2.
> [#:phases]<qualify-programs>: Also expand pgrep.
> [inputs]: Add procps. Replace at-spi2-atk with at-spi2-core.
Pushed.  Next time, use two spaces please, I forgot to fix that ^^"
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..bfc16159c0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11089,7 +11089,7 @@  (define-public python-pyatspi
 (define-public orca
   (package
     (name "orca")
-    (version "42.3")
+    (version "44.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -11098,17 +11098,25 @@  (define-public orca
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "097pyav3z5ssic8vwd7v1s7vynpycdpyfr324rr6c7mfzq5vmp7s"))))
+                "11jn925ga970y74did96ms78pc3lshkd9rd8v82i6zdzigxa7yvd"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'qualify-xkbcomp
+         (add-before 'configure 'qualify-programs
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((xkbcomp (string-append
-                             (assoc-ref inputs "xkbcomp") "/bin/xkbcomp")))
+                             (assoc-ref inputs "xkbcomp") "/bin/xkbcomp"))
+                   (pgrep (string-append
+                           (assoc-ref inputs "procps") "/bin/pgrep")))
                (substitute* "src/orca/orca.py"
-                 (("'xkbcomp'") (format #f "'~a'" xkbcomp))))))
+                 (("'xkbcomp'") (format #f "'~a'" xkbcomp)))
+               (substitute* "src/orca/debug.py"
+                 (("'pgrep %s'")
+                  (format #f "'~a %s'" pgrep)))
+               (substitute* "src/orca/orca_bin.py.in"
+                 (("'pgrep -u %s -x orca'")
+                  (format #f "'~a -u %s -x orca'" pgrep))))))
          (add-after 'install 'wrap-orca
            (lambda* (#:key outputs #:allow-other-keys)
              (wrap-program (search-input-file outputs "bin/orca")
@@ -11124,13 +11132,14 @@  (define-public orca
            pkg-config
            libxml2))
     (inputs
-     (list at-spi2-atk
+     (list at-spi2-core
            bash-minimal
            gsettings-desktop-schemas
            gstreamer
            gst-plugins-base
            gst-plugins-good
            gtk+
+           procps                       ; for pgrep
            python
            python-pygobject
            python-pyatspi