diff mbox series

[bug#71897,4/5] gnu: Add libprisma-for-telegram-desktop.

Message ID 80dd2fffb3b605252f0cbea2bf802e8345c15eec.1720364199.git.i@dan.games
State New
Headers show
Series [bug#71897,1/5] gnu: xdg-desktop-portal: Update to 1.18.4. | expand

Commit Message

dan July 7, 2024, 3 p.m. UTC
* gnu/packages/telegram.scm (libprisma-for-telegram-desktop): New variable.

Change-Id: I855b463993654a8cad491c7b56c9581b3083f5e4
---
 gnu/packages/telegram.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Maxim Cournoyer July 9, 2024, 2:29 a.m. UTC | #1
Hi,

dan <i@dan.games> writes:

> * gnu/packages/telegram.scm (libprisma-for-telegram-desktop): New variable.
>
> Change-Id: I855b463993654a8cad491c7b56c9581b3083f5e4
> ---
>  gnu/packages/telegram.scm | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
>
> diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
> index 26ab27293f..0a48361eb4 100644
> --- a/gnu/packages/telegram.scm
> +++ b/gnu/packages/telegram.scm
> @@ -400,6 +400,18 @@ (define cld3-for-telegram-desktop
>      (base32
>       "0ayrrhfdwrf4260h9fsirkhhfrcvc3qqnh6h9wj3ixij2lq0wwqb"))))
>  
> +(define libprisma-for-telegram-desktop
> +  (origin
> +   (method git-fetch)
> +   (uri (git-reference
> +         (url "https://github.com/desktop-app/libprisma")
> +         (commit "23b0d70f9709da9b38561d5706891a134d18df76")))
> +   (file-name
> +    (git-file-name "libprisma-for-telegram-desktop" "5.2.3"))
> +   (sha256
> +    (base32
> +     "0fg4x4ikj7f3706bmfvkwq4smxc98qr3cgpm25w48n4ys6wfgadg"))))
> +

So this is built as part of telegram?  If this doesn't have any proper
build system to be built separately and linked, or if telegram lacks
such a feature in its own build system (I like to report such feature
request for that to upstream myself), another perhaps more maintainable
strategy would be to use recursive? #t on the git-reference to clone
these, and delete in a source snippet the submodules we don't want to
have.

Otherwise, OK!
Maxim Cournoyer July 9, 2024, 11:54 a.m. UTC | #2
Hi Dan,

dan <i@dan.games> writes:

> Hi Maxim,
>
> On 7/9/2024 10:29 AM, Maxim Cournoyer wrote:
>> Hi,
>> dan <i@dan.games> writes:
>> 
>>> * gnu/packages/telegram.scm (libprisma-for-telegram-desktop): New variable.
>>>
>>> Change-Id: I855b463993654a8cad491c7b56c9581b3083f5e4
>>> ---
>>>   gnu/packages/telegram.scm | 12 ++++++++++++
>>>   1 file changed, 12 insertions(+)
>>>
>>> diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
>>> index 26ab27293f..0a48361eb4 100644
>>> --- a/gnu/packages/telegram.scm
>>> +++ b/gnu/packages/telegram.scm
>>> @@ -400,6 +400,18 @@ (define cld3-for-telegram-desktop
>>>       (base32
>>>        "0ayrrhfdwrf4260h9fsirkhhfrcvc3qqnh6h9wj3ixij2lq0wwqb"))))
>>>   +(define libprisma-for-telegram-desktop
>>> +  (origin
>>> +   (method git-fetch)
>>> +   (uri (git-reference
>>> +         (url "https://github.com/desktop-app/libprisma")
>>> +         (commit "23b0d70f9709da9b38561d5706891a134d18df76")))
>>> +   (file-name
>>> +    (git-file-name "libprisma-for-telegram-desktop" "5.2.3"))
>>> +   (sha256
>>> +    (base32
>>> +     "0fg4x4ikj7f3706bmfvkwq4smxc98qr3cgpm25w48n4ys6wfgadg"))))
>>> +
>> So this is built as part of telegram?  If this doesn't have any
>> proper
>> build system to be built separately and linked, or if telegram lacks
>> such a feature in its own build system (I like to report such feature
>> request for that to upstream myself), another perhaps more maintainable
>> strategy would be to use recursive? #t on the git-reference to clone
>> these, and delete in a source snippet the submodules we don't want to
>> have.
>
> Most of the dependencies of telegram-desktop are packaged this way, so
> here I'm more or less following the convention. de If we decide to use
> recursive? #t, I think it's better to fully revamp the packaging of
> telegram-desktop.  libprisma itself doesn't have a build system, and I
> think it's only used in telegram-desktop.

OK, fair enough.  Thanks for the explanation (I also noticed the tens of
git submodules as source variables in a later commit).

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 26ab27293f..0a48361eb4 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -400,6 +400,18 @@  (define cld3-for-telegram-desktop
     (base32
      "0ayrrhfdwrf4260h9fsirkhhfrcvc3qqnh6h9wj3ixij2lq0wwqb"))))
 
+(define libprisma-for-telegram-desktop
+  (origin
+   (method git-fetch)
+   (uri (git-reference
+         (url "https://github.com/desktop-app/libprisma")
+         (commit "23b0d70f9709da9b38561d5706891a134d18df76")))
+   (file-name
+    (git-file-name "libprisma-for-telegram-desktop" "5.2.3"))
+   (sha256
+    (base32
+     "0fg4x4ikj7f3706bmfvkwq4smxc98qr3cgpm25w48n4ys6wfgadg"))))
+
 (define cppgir-for-telegram-desktop
   (let ((commit "9c4f5820d94d62ab451501f016bfea97156518f4")
         (revision "0"))