diff mbox series

[bug#71319,v2,3/3] gnu: emacs-ddskk-nicola: Improve package style.

Message ID 80aa9ac79b1b8577ce04dec98909fb9e2d0bf9fc.1718104831.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#71319,v2,1/3] gnu: emacs-ddskk: Update to 17.1 revision 0. | expand

Commit Message

gemmaro June 11, 2024, 11:20 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]: Use newer
package style.  This is necessary due to the emacs-ddskk package style update
since emacs-ddskk-nicola inherits this.  It also removes the last #t values
from the lambda expressions in phases.

Change-Id: Ief8761bca476eba5e675d995b22d0a070f90de2f
---
 gnu/packages/emacs-xyz.scm | 38 +++++++++++++++++++-------------------
 1 file changed, 19 insertions(+), 19 deletions(-)

Comments

Nicolas Goaziou June 19, 2024, 11:14 a.m. UTC | #1
Hello,

gemmaro <gemmaro.dev@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]: Use newer
> package style.  This is necessary due to the emacs-ddskk package style update
> since emacs-ddskk-nicola inherits this.  It also removes the last #t values
> from the lambda expressions in phases.

Thank you. Some comments follow.

> +     (append
> +      (list #:make-flags
> +            #~(let ((out (assoc-ref %outputs "out")))

You can remove this and use #$output instead.

> +                (append
> +                 (list (string-append "PREFIX=" out)
> +                       (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))

See above.

> +            #:tests? #f                 ;no tests in this subtree
> +            )

Please do not leave dangling parenthesis like this one.

> +      (substitute-keyword-arguments (package-arguments emacs-ddskk)
> +        ((#:phases phases)
> +         #~(modify-phases #$phases
> +             (add-after 'unpack 'chdir
> +               (lambda _
> +                 (chdir "nicola")))
> +             (replace 'configure
> +               (lambda* (#:key outputs #:allow-other-keys)
> +                 (make-file-writable "NICOLA-DDSKK-CFG")
> +                 (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
> +                   ("setq NICOLA-DDSKK_PREFIX" "")))))))))

You can use (lambda _ ...) instead of (lambda* (#:key outputs ...) ...)
since you don't make use of OUTPUTS argument.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e6f5eb356c..4690fffc56 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36894,25 +36894,25 @@  (define-public emacs-ddskk-nicola
     (propagated-inputs
      (list emacs-ddskk))
     (arguments
-     `(#:make-flags
-       (let ((out (assoc-ref %outputs "out")))
-         (append
-          (list (string-append "PREFIX=" out)
-                (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
-       #:tests? #f                      ; no tests in this subtree
-       ,@(substitute-keyword-arguments (package-arguments emacs-ddskk)
-           ((#:phases phases)
-            `(modify-phases ,phases
-               (add-after 'unpack 'chdir
-                 (lambda _
-                   (chdir "nicola")
-                   #t))
-               (replace 'configure
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (make-file-writable "NICOLA-DDSKK-CFG")
-                   (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
-                     ("setq NICOLA-DDSKK_PREFIX" ""))
-                   #t)))))))
+     (append
+      (list #:make-flags
+            #~(let ((out (assoc-ref %outputs "out")))
+                (append
+                 (list (string-append "PREFIX=" out)
+                       (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
+            #:tests? #f                 ;no tests in this subtree
+            )
+      (substitute-keyword-arguments (package-arguments emacs-ddskk)
+        ((#:phases phases)
+         #~(modify-phases #$phases
+             (add-after 'unpack 'chdir
+               (lambda _
+                 (chdir "nicola")))
+             (replace 'configure
+               (lambda* (#:key outputs #:allow-other-keys)
+                 (make-file-writable "NICOLA-DDSKK-CFG")
+                 (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
+                   ("setq NICOLA-DDSKK_PREFIX" "")))))))))
     (synopsis "Nicola layout for Daredevil SKK")
     (description
      "Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji