diff mbox series

[bug#70924,06/10] gnu: Add python-pyproject-api.

Message ID 80a138c1893532ec9188fd0905cbaaa583a6c609.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyproject-api): New variable.

Change-Id: I4bef06ecebcf3c5df99196b75017a4d97c7f2dda
---
 gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79c7b310d4..521005174e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17179,6 +17179,41 @@  (define-public python-forex-python
 @end itemize")
     (license license:expat)))
 
+(define-public python-pyproject-api
+  (package
+    (name "python-pyproject-api")
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyproject_api" version))
+       (sha256
+        (base32 "0f75rajzk72ay4x9ajw1835amm932q7cdn0yrbwiy3fwi80xq5qq"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      ;; This test fails with AssertionError.
+      #~(list "-k" "not test_setuptools_prepare_metadata_for_build_wheel")
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'relax-packaging
+                     (lambda _
+                       (substitute* "pyproject.toml"
+                         ;; We have packaging 21.3.
+                         (("packaging>=23.1") "packaging>=21.3")))))))
+    (propagated-inputs (list python-packaging python-tomli))
+    (native-inputs (list python-covdefaults
+                         python-hatch-vcs
+                         python-hatchling
+                         python-pytest
+                         python-pytest-cov
+                         python-pytest-mock))
+    (home-page "https://pyproject-api.readthedocs.io/en/latest/")
+    (synopsis "API to interact with the Python pyproject.toml based projects")
+    (description "@code{pyproject-api} aims to abstract away interaction with
+@code{pyproject.toml} style projects in a flexible way.")
+    (license license:expat)))
+
 (define-public python-simpleeval
   (package
     (name "python-simpleeval")