diff mbox series

[bug#57625,v1,02/03] gnu: Add treecc.

Message ID 809493d4-0a97-e04c-73df-e0d2f75402cb@disroot.org
State New
Headers show
Series [bug#57625,v1,01/03] gnu: Add libgc-all-headers. | expand

Checks

Context Check Description
cbaines/applying patch fail
cbaines/issue success View issue

Commit Message

Adam Faiz Nov. 18, 2022, 9:20 a.m. UTC
On 11/18/22 17:15, Adam Faiz wrote:
 From 38a45d7451442a4905cab043adb5f3a514929495 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 08:31:56 +0800
Subject: [PATCH v1 02/03] gnu: Add treecc.

* gnu/packages/dotgnu.scm: New file.
---
  gnu/packages/dotgnu.scm | 50 +++++++++++++++++++++++++++++++++++++++++
  1 file changed, 50 insertions(+)
  create mode 100644 gnu/packages/dotgnu.scm

handle
+abstract syntax trees and operations upon the trees.")
+    (license license:gpl2+)))
diff mbox series

Patch

diff --git a/gnu/packages/dotgnu.scm b/gnu/packages/dotgnu.scm
new file mode 100644
index 0000000000..ad3b6c74e5
--- /dev/null
+++ b/gnu/packages/dotgnu.scm
@@ -0,0 +1,50 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dotgnu)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses)
+                #:prefix license:)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bdw-gc)
+  #:use-module (gnu packages libffi))
+
+(define-public treecc
+  (package
+    (name "treecc")
+    (version "0.3.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+ 
"https://download.savannah.gnu.org/releases/dotgnu-pnet/treecc-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1rzgnspg2xccdq3qsx0vi3j28h4qkrzbrjnhzvnny34fjfk217ay"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnu.org/software/dotgnu/")
+    (synopsis "Abstract syntax tree compiler compiler")
+    (description
+     "The treecc program is designed to assist in the development of 
compilers
+and other language-based tools.  It manages the generation of code to