diff mbox series

[bug#71076,50/81] gnu: Add rust-hyper-rustls-0.27.

Message ID 808d1b55c6cfa1beb8a4c5762d372298fddeb291.1716193123.git.herman@rimm.ee
State New
Headers show
Series Add matrix-conduit and ruma-0.10. | expand

Commit Message

Herman Rimm May 20, 2024, 8:58 a.m. UTC
* gnu/packages/crates-web.scm (rust-hyper-rustls-0.27): Add variable.
(rust-hyper-rustls-0.24): Inherit from rust-hyper-rustls-0.27.

Change-Id: Idc2d731a72f3ed88adf27a7fc4793a97382df691
---
 gnu/packages/crates-web.scm | 52 ++++++++++++++++++++++++++++++++-----
 1 file changed, 45 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 6629bc9327..8291a42318 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -33,6 +33,7 @@  (define-module (gnu packages crates-web)
   #:use-module (guix utils)
   #:use-module (guix gexp)
   #:use-module (gnu packages)
+  #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crates-apple)
   #:use-module (gnu packages crates-crypto)
@@ -3746,8 +3747,51 @@  (define-public rust-hyper-proxy-0.9
     (description "Proxy connector for the Hyper HTTP library.")
     (license license:expat)))
 
+(define-public rust-hyper-rustls-0.27
+  (package
+    (name "rust-hyper-rustls")
+    (version "0.27.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hyper-rustls" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+          "0arh47qg9ln3l8q4x9wcpwmsq4j1cc08mimw3sh3g86pjs3b72wh"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:cargo-inputs (list rust-futures-util-0.3
+                           rust-http-1
+                           rust-hyper-1
+                           rust-hyper-util-0.1
+                           rust-log-0.4
+                           rust-rustls-0.23
+                           rust-rustls-native-certs-0.7
+                           rust-rustls-pki-types-1
+                           rust-rustls-platform-verifier-0.3
+                           rust-tokio-1
+                           rust-tokio-rustls-0.26
+                           rust-tower-service-0.3
+                           rust-webpki-roots-0.26)
+      #:cargo-development-inputs (list rust-http-body-util-0.1
+                                       rust-hyper-util-0.1
+                                       rust-rustls-0.23
+                                       rust-rustls-pemfile-2
+                                       rust-tokio-1)))
+    (native-inputs (list cmake-minimal))
+    (home-page "https://github.com/rustls/hyper-rustls")
+    (synopsis "Rustls+hyper integration for pure rust HTTPS")
+    (description
+     "This package provides Rustls+hyper integration for pure rust
+HTTPS.")
+    (license (list license:asl2.0 license:isc license:expat))))
+
 (define-public rust-hyper-rustls-0.24
   (package
+    (inherit rust-hyper-rustls-0.27)
     (name "rust-hyper-rustls")
     (version "0.24.2")
     (source
@@ -3757,7 +3801,6 @@  (define-public rust-hyper-rustls-0.24
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1475j4a2nczz4aajzzsq3hpwg1zacmzbqg393a14j80ff8izsgpc"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:tests? #f              ; Not all files included.
        #:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
@@ -3772,12 +3815,7 @@  (define-public rust-hyper-rustls-0.24
        #:cargo-development-inputs (("rust-hyper" ,rust-hyper-0.14)
                                    ("rust-rustls" ,rust-rustls-0.21)
                                    ("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
-                                   ("rust-tokio" ,rust-tokio-1))))
-    (home-page "https://github.com/rustls/hyper-rustls")
-    (synopsis "Rustls+Hyper integration for pure Rust HTTPS")
-    (description
-     "This package provides Rustls+Hyper integration for pure Rust HTTPS.")
-    (license (list license:asl2.0 license:isc license:expat))))
+                                   ("rust-tokio" ,rust-tokio-1))))))
 
 (define-public rust-hyper-rustls-0.23
   (package