[bug#74723,19/19] gnu: carla-2.6: Update to 2.6.0-1.17000e7.

Message ID 807df3c51122c79701e7e24a27a25ac15bd8edbc.1733563475.git.sughosha@disroot.org
State New
Headers
Series gnu: lmms, carla: New features, fixes and updates. |

Commit Message

Sughosha Dec. 7, 2024, 12:20 p.m. UTC
  * gnu/packages/audio.scm (carla-2.6): Update to 2.6.0.-1.17000e7.
[inputs]: Replace python-pyqt with python-pyqt-6, qtbase-5 with qtbase
and qtwayland-5 with qtwayland.

Change-Id: Ic64f344a9e509bd9bf7963606002e66355b2231f
---
 gnu/packages/audio.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f7cb4893be..4fcda11698 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5923,8 +5923,8 @@  (define-public carla-2.4
 
 ;;; This package variant tracks the latest in-development 2.6 release.
 (define-public carla-2.6
-  (let ((commit "aa400535b31c67f4b6c1b28e6e20e4d4f82111a3")
-        (revision "0"))
+  (let ((commit "17000e7fe99459b25a50094a8b00bdfa12f2bfbc")
+        (revision "1"))
     (package
       (inherit carla)
       (name "carla")
@@ -5938,7 +5938,12 @@  (define-public carla-2.6
            (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0cnj2sgr60f5h6wdfmihc214wf3n74686sipl3iyzmylqrcyhbjn")))))))
+          (base32 "1bils2xr4zv4z70al0rg6bc1ijvn2cq6macq11skx7gzjlcw09bq"))))
+      (inputs
+       (modify-inputs (package-inputs carla-2.6)
+         (replace "python-pyqt" python-pyqt-6)
+         (replace "qtbase" qtbase)
+         (replace "qtwayland" qtwayland))))))
 
 (define-public ecasound
   (package