[bug#76005] gnu: wlogout: Fix paths to assets
Commit Message
* gnu/packages/wm.scm (wlogout): [#:phases]
<patch-source-paths>: Substitute paths in style.css.
Change-Id: I128581608e29294cbc4165e9ebd7d1e505e90b4f
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
base-commit: b64d3168af697ceb2a96e7e2c62bcf418b8a586a
Comments
user guix
usertag 76005 + reviewed-looks-good
thanks
Guix QA review form submission:
I would reword a bit the commit message (adding a dot, and I also often
use [arguments]<#:phases> instead). Otherwise LGTM, I can confirm the
claimed fix indeed happens (checked with diffoscope). Marking as
reviewed-looks-good.
Items marked as checked: Lint warnings, Package builds
@@ -75,7 +75,7 @@
;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
-;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024, 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;; Copyright © 2025 Tomáš Čech <sleep_walker@gnu.org>
@@ -3804,7 +3804,7 @@ (define-public wlogout
(add-after 'unpack 'patch-source-paths
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (substitute* "main.c"
+ (substitute* (list "main.c" "style.css")
(("/usr/share") (string-append out "/share"))
(("/etc") (string-append out "/etc"))))
#t)))))