@@ -204,7 +204,7 @@ (define-public python-django python-django-3.2)
(define-public python-django-extensions
(package
(name "python-django-extensions")
- (version "3.0.6")
+ (version "3.2.0")
(source
(origin
(method git-fetch)
@@ -214,11 +214,11 @@ (define-public python-django-extensions
(commit version)))
(file-name (string-append name "-" version))
(sha256
- (base32
- "0sra6hazqvspxd1pnx5cj7gia1rkaz3hn06ib4wd0frc167f5afy"))))
- (build-system python-build-system)
- (arguments
- '(#:tests? #f)) ;XXX: requires a Postgres or MySQL database
+ (base32 "1wfzlfjbicvk093xqx3qw633ap2khk6kc1ph2kwfk72wxy8yq9lf"))
+ (snippet ; Disable pip-dependent tests.
+ '(delete-file "tests/management/commands/test_pipchecker.py"))))
+ (build-system pyproject-build-system)
+ ;; TODO More tests can be enabled with a Postgres or MySQL database
(propagated-inputs
(list python-six python-vobject python-werkzeug python-dateutil
python-django))
@@ -226,10 +226,12 @@ (define-public python-django-extensions
(list python-mock
python-factory-boy
python-tox
+ python-pygments
python-pytest
python-pytest-cov
python-pytest-django
- python-shortuuid))
+ python-shortuuid
+ tzdata-for-tests))
(home-page
"https://github.com/django-extensions/django-extensions")
(synopsis "Custom management extensions for Django")