[bug#76026] gnu: cogl: Disable gstreamer plugin.

Message ID 804e33c6f779448024d40795f1f92eda5d5aa068.1738564364.git.iyzsong@member.fsf.org
State New
Headers
Series [bug#76026] gnu: cogl: Disable gstreamer plugin. |

Commit Message

vasilii.smirnov--- via Guix-patches" via Feb. 3, 2025, 6:32 a.m. UTC
  From: 宋文武 <iyzsong@member.fsf.org>

Fixes <https://issues.guix.gnu.org/39126>.

The cogl GStreamer sink has been broken:
  <https://gitlab.gnome.org/Archive/cogl/-/issues/15>

* gnu/packages/gnome.scm (cogl)[inputs]: Remove gstreamer and
gst-plugins-base.
[arguments]: Pass "--enable-cogl-gst=no" to configure-flags.

Change-Id: I644da53effb52c6b6d8b1f9b6df293545fab963c
---
 gnu/packages/gnome.scm | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)


base-commit: 12619742365b4bc138853ff7d79053e2089ffe1e
  

Comments

Maxim Cournoyer Feb. 3, 2025, 1:08 p.m. UTC | #1
Hello!

iyzsong@envs.net writes:

> From: 宋文武 <iyzsong@member.fsf.org>
>
> Fixes <https://issues.guix.gnu.org/39126>.
>
> The cogl GStreamer sink has been broken:
>   <https://gitlab.gnome.org/Archive/cogl/-/issues/15>
>
> * gnu/packages/gnome.scm (cogl)[inputs]: Remove gstreamer and
> gst-plugins-base.
> [arguments]: Pass "--enable-cogl-gst=no" to configure-flags.

Awesome, you are fixing a 5 years old bug :-).  Nitpick, I'd used

--8<---------------cut here---------------start------------->8---
Fixes: <https://issues.guix.gnu.org/39126>
--8<---------------cut here---------------end--------------->8---

at the bottom of your git commit message, next to the Change-Id (these
are git trailers, must be placed at the bottom of the git message, see
'man git-interpret-trailers').

> Change-Id: I644da53effb52c6b6d8b1f9b6df293545fab963c
> ---
>  gnu/packages/gnome.scm | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 1225570c3c..1e8d813682 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -6308,12 +6308,10 @@ (define-public cogl
>       (list mesa
>             cairo
>             pango
> -           gstreamer
> -           gst-plugins-base
>             wayland))
>      (arguments
>       `(#:disallowed-references (,xorg-server-for-tests)
> -       #:configure-flags (list "--enable-cogl-gst"
> +       #:configure-flags (list "--enable-cogl-gst=no" ;broken and unmaintained
>                                 "--enable-wayland-egl-platform"
>                                 "--enable-wayland-egl-server"

That looks good to me, but reading
https://blogs.gnome.org/clutter/2022/02/16/retiring-clutter/, it seems
we should instead be removing cogl from the distribution, or at least
never propagating it, in which case the above flag would become
unnecessary.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
  
宋文武 Feb. 3, 2025, 2:09 p.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Awesome, you are fixing a 5 years old bug :-).  Nitpick, I'd used
>
> Fixes: <https://issues.guix.gnu.org/39126>

Done, thank you!

> [...]
> That looks good to me, but reading
> https://blogs.gnome.org/clutter/2022/02/16/retiring-clutter/, it seems
> we should instead be removing cogl from the distribution, or at least
> never propagating it, in which case the above flag would become
> unnecessary.

Yes, It's propagated and needed by clutter, which still required by 22
packages.  GNOME propagated it by cheese, where cheese.pc does requires
cluster.  So I think remove the cogl gst plugin is right thing to do
here.
  
Maxim Cournoyer Feb. 4, 2025, 2:21 a.m. UTC | #3
Hi,

宋文武 <iyzsong@envs.net> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Awesome, you are fixing a 5 years old bug :-).  Nitpick, I'd used
>>
>> Fixes: <https://issues.guix.gnu.org/39126>
>
> Done, thank you!
>
>> [...]
>> That looks good to me, but reading
>> https://blogs.gnome.org/clutter/2022/02/16/retiring-clutter/, it seems
>> we should instead be removing cogl from the distribution, or at least
>> never propagating it, in which case the above flag would become
>> unnecessary.
>
> Yes, It's propagated and needed by clutter, which still required by 22
> packages.  GNOME propagated it by cheese, where cheese.pc does requires
> cluster.  So I think remove the cogl gst plugin is right thing to do
> here.

cheese has been replaced by snapshot, so we should remove it from the
gnome core applications [0]

[0]  https://gitlab.gnome.org/Teams/Releng/AppOrganization/-/issues/8#note_1820268
  
Vivien Kraus Feb. 4, 2025, 5:46 a.m. UTC | #4
Hello,

Le mardi 04 février 2025 à 11:21 +0900, Maxim Cournoyer a écrit :
> cheese has been replaced by snapshot,

As far as I understand, snapshot is Rust, so I understand why we would
want to keep cheese around also.

Best regards,

Vivien
  
Maxim Cournoyer Feb. 5, 2025, 1:58 a.m. UTC | #5
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> Hello,
>
> Le mardi 04 février 2025 à 11:21 +0900, Maxim Cournoyer a écrit :
>> cheese has been replaced by snapshot,
>
> As far as I understand, snapshot is Rust, so I understand why we would
> want to keep cheese around also.

GNOME already pulls librsvg, which is rust-written as well, so it's not
that big of deal; especially since it can be conditionally added via
(supported-package? snapshot).  The bigger deal is getting it packaged
:-).
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1225570c3c..1e8d813682 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6308,12 +6308,10 @@  (define-public cogl
      (list mesa
            cairo
            pango
-           gstreamer
-           gst-plugins-base
            wayland))
     (arguments
      `(#:disallowed-references (,xorg-server-for-tests)
-       #:configure-flags (list "--enable-cogl-gst"
+       #:configure-flags (list "--enable-cogl-gst=no" ;broken and unmaintained
                                "--enable-wayland-egl-platform"
                                "--enable-wayland-egl-server"