diff mbox series

[bug#41553] gnu: Add spectacle-analyzer.

Message ID 801ede06b909043f31f507696993af64c2c80056.camel@zrythm.org
State Accepted
Headers show
Series [bug#41553] gnu: Add spectacle-analyzer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou May 27, 2020, 12:44 a.m. UTC
Hi,

This patch adds spectacle analyzer, an LV2 graphical spectrum analyzer
(audio plugin).

Thanks,
Alex
diff mbox series

Patch

From 8fa72560cb851d63eff6c8c77a1bc05bd4f5c820 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 27 May 2020 01:41:39 +0100
Subject: [PATCH] gnu: Add spectacle-analyzer.

* gnu/packages/music.scm (spectacle-analyzer): new variable.
---
 gnu/packages/music.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9cfda8e88c..4edb4dccf3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4935,6 +4935,47 @@  and debugging of event signal flows inside plugin graphs.")
     (home-page "https://open-music-kontrollers.ch/lv2/sherlock/")
     (license license:artistic2.0)))
 
+(define-public spectacle-analyzer
+  (package
+    (name "spectacle-analyzer")
+    (version "1.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/jpcima/spectacle.git")
+               (commit (string-append "v" version))
+               ;; Bundles a specific commit of the DISTRHO plugin framework.
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0xiqa6z8g68lcvnwhws4j7c4py35r9d20cirrili7ycyp3a6149a"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no check target
+       #:make-flags
+       (list "CC=gcc"
+             (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("xxd" ,xxd)))
+    (inputs
+      `(("cairo", cairo)
+        ("fftw", fftw)
+        ("fftwf", fftwf)
+        ("jack", jack-1)
+        ("lv2", lv2)
+        ("mesa", mesa)))
+    (synopsis "Realtime graphical spectrum analyzer")
+    (description "Spectacle is a real-time spectral analyzer using the
+short-time Fourier transform, available as LV2 audio plugin and JACK client.")
+    (home-page "https://github.com/jpcima/spectacle")
+    (license license:isc)))
+
 (define-public x42-plugins
   (package
     (name "x42-plugins")
-- 
2.26.2