diff mbox series

[bug#66579,10/13] gnu: Add rust-librespot-audio.

Message ID 8019566112382b8c474465e4201ec1bd82e7e81e.1697475045.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 16, 2023, 4:54 p.m. UTC
* gnu/packages/crates-io.scm (rust-librespot-audio): New variable.
---
 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Christopher Baines Oct. 20, 2023, 9:30 a.m. UTC | #1
Steve George <steve@futurile.net> writes:

> * gnu/packages/crates-io.scm (rust-librespot-audio): New variable.
> ---
>  gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index ffc7891ee8..100a5ee645 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -35587,6 +35587,35 @@ (define-public rust-libradicl-0.4
>  single-cell and single-nucleus sequencing data.")
>      (license license:bsd-3)))
>  
> +(define-public rust-librespot-audio-0.4
> +  (package
> +    (name "rust-librespot-audio")
> +    (version "0.4.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "librespot-audio" version))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32 "178djijj7fkg5ca5rhk10rvy9gs797gikvackh5qxsp1al9s6xn1"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     (list #:skip-build? #f
> +           #:cargo-inputs `(("rust-aes-ctr" ,rust-aes-ctr-0.6)

rust-aes-ctr-0.6 doesn't seem to be defined, which is what has led to QA
failing to process these changes.
Steve George Oct. 20, 2023, 5:02 p.m. UTC | #2
On 20/10/2023 10:30, Christopher Baines wrote:
(...)
> rust-aes-ctr-0.6 doesn't seem to be defined, which is what has led to QA
> failing to process these changes.
> 

Hi - thanks for the heads-up - I got confused and mistakenly thought 
rust-aes-ctr-0.6 was already there. I have it locally so will add and 
re-roll them.

Thanks,

Steve
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ffc7891ee8..100a5ee645 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35587,6 +35587,35 @@  (define-public rust-libradicl-0.4
 single-cell and single-nucleus sequencing data.")
     (license license:bsd-3)))
 
+(define-public rust-librespot-audio-0.4
+  (package
+    (name "rust-librespot-audio")
+    (version "0.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "librespot-audio" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "178djijj7fkg5ca5rhk10rvy9gs797gikvackh5qxsp1al9s6xn1"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #f
+           #:cargo-inputs `(("rust-aes-ctr" ,rust-aes-ctr-0.6)
+                            ("rust-byteorder" ,rust-byteorder-1)
+                            ("rust-bytes" ,rust-bytes-1)
+                            ("rust-futures-util" ,rust-futures-util-0.3)
+                            ("rust-librespot-core" ,rust-librespot-core-0.4)
+                            ("rust-log" ,rust-log-0.4)
+                            ("rust-tempfile" ,rust-tempfile-3)
+                            ("rust-tokio" ,rust-tokio-1))))
+    (home-page "https://github.com/librespot-org/librespot")
+    (synopsis "The audio fetching logic for Librespot")
+    (description
+     "Part of Librespot, an open source client library
+for Spotify.  This package contains the audio fetching logic.")
+    (license license:expat)))
+
 (define-public rust-librespot-core-0.4
   (package
     (name "rust-librespot-core")