diff mbox series

[bug#59999] gnu: Add nwg-launchers.

Message ID 7kzutiqUZPVX5s3r9I5MGOLd1adGzoUH-6kWLJIiBYLsAcccd-nOZwJTZGTYA1DcKqDB_hvf7uQ8QeeQw9GtcujfeIoNq_jifECYEaa8C5I=@proton.me
State New
Headers show
Series [bug#59999] gnu: Add nwg-launchers. | expand

Commit Message

Sughosha Jan. 27, 2023, 4:44 p.m. UTC
I cannot merge the v2 patch into my local branch. I had nwg-launchers in my
local branch in xdisorg.scm but had not submitted the patch till now. The reason
for having it in xdisorg.scm is that I found similar packages like wofi and many
other launchers there. Here is the patch that I have.

* gnu/packages/xdisorg.scm (nwg-launchers): New variable.
---
 gnu/packages/xdisorg.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

--
libgit2 1.4.3

Comments

Josselin Poiret March 3, 2023, 8:45 a.m. UTC | #1
Hi Sughosha,

Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

> I cannot merge the v2 patch into my local branch. I had nwg-launchers in my
> local branch in xdisorg.scm but had not submitted the patch till now. The reason
> for having it in xdisorg.scm is that I found similar packages like wofi and many
> other launchers there. Here is the patch that I have.

Patch looks good to me (it is in fact GPLv3 and not Expat). I don't
think there's any other module that would be a better home for this
package, although the name itself is unfortunate.

Best,
Vagrant Cascadian Sept. 2, 2023, 4:48 a.m. UTC | #2
On 2023-01-27, Sughosha wrote:
> +(define-public nwg-launchers
> +  (package
> +    (name "nwg-launchers")
> +    (version "0.7.1.1")

Merged as:

39c50eb49540bbc90b20152520be4fd095d5f979 gnu: Add nwg-launchers.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index f6f0157..5f7d63d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -97,6 +97,7 @@ 
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
@@ -3061,6 +3062,29 @@  such as sway, similar to @command{rofi}.")
     (home-page "https://hg.sr.ht/~scoopta/wofi")
     (license license:gpl3+)))
 
+(define-public nwg-launchers
+  (package
+    (name "nwg-launchers")
+    (version "0.7.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nwg-piotr/nwg-launchers")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
+    (build-system meson-build-system)
+    (native-inputs (list json-modern-cxx pkg-config))
+    (inputs (list gtk-layer-shell gtkmm-3 librsvg))
+    (home-page "https://github.com/nwg-piotr/nwg-launchers")
+    (synopsis "GTK-based launchers")
+    (description
+     "This package provides application grid, button bar and dmenu applications
+for sway and other window managers.")
+    (license license:gpl3+)))
+
 (define-public dex
   (package
     (name "dex")