diff mbox series

[bug#41010] Upgrade Oil to 0.8.pre4

Message ID 7j_T0Kf3tHwi7uYPSXZUYLjdVXe_LWrzbgE6XY7mdt-HZsxZQhTuCs8-H4kISkUui_q7IL1BrSnkCIksY62JtGWP-_gXsDC3MBnfusZzcOA=@protonmail.com
State Accepted
Headers show
Series [bug#41010] Upgrade Oil to 0.8.pre4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via May 2, 2020, 4:02 a.m. UTC
Tobias, thank you for the quick and thorough review! I've attached updated patches.

A little context on how this patch came to be might make some of my choices a little less mysterious: I didn't actually start with the original package definition, because I didn't realize oil was already packaged in Guix. (I searched for "osh", not "oil-shell")

So I wrote my own package, went to find where to put it in the guix source tree, found the existing package, and then kinda merged them together.



On Friday, May 1, 2020 11:23 PM, Tobias Geerinckx-Rice <me@tobias.gr> wrote:

> However, please do build and test patches before submitting them.

Done! I test my packages mostly by running `guix build -f mypackage.scm` so I had to figure out how to build it in the context of the source tree.

> Add a full stop after commit summaries, and a ‘change log’ entry as commit body:

Added.

> OTOH a one-line link to that thread, if one exists, would be preferable.

Changed to a one-line link.

> Where do they recommend this? It's nice to have a link in case the recommendation changes.

Added a link to the recommendation.


> …as ‘guix gc --references oil’ (and readline's general nature) tell us, that's not the case here: Oil links to it at run time, so it must not be native.

I changed it to a normal input.

> Both the original synopsis and description are much better. If certain things are no longer accurate they can be adjusted but this is just upstream's marketing pitch.

I did ask upstream what they'd want as a synopsis/description. I updated it to be more similar to the original but edited for accuracy.

>
> > -   (license (list license:psfl ; Tarball vendors python2.7
>
> Hmm, this doesn't parse as English (it's missing a verb). I'd guess typo… but for what? Are upstream the ‘tarball vendors’ here? What was wrong with the original comment?

In some software development circles, we do use "vendor" as a verb. Sorry for the confusion!

>vendor (third-person singular simple present vendors, present participle vendoring, simple past and past participle vendored)
>
>    (transitive, software development) To bundle third-party dependencies with the source code for one's own program.
>
>        I distributed my application with a vendored copy of Perl so that it wouldn't use the system copies of Perl where it is installed.
https://en.wiktionary.org/wiki/vendor

In favor of readability I changed the verb to "includes."

> Phew. ‘I'll just review this trivial bump before bed-time.’ This patch changes lots of things for one small package. I hope you don't mind lots of comments :-)

Thank you again, I appreciated all the comments!

Sincerely,
Ryan

Comments

guix--- via Guix-patches via May 15, 2020, 5:10 p.m. UTC | #1
Ryan Prior <rprior@protonmail.com> writes:

> Tobias, thank you for the quick and thorough review! I've attached updated patches.

Any thoughts on this updated patch would be welcome if there are still
issues to be address before merging!

Thanks,
Ryan
guix--- via Guix-patches via May 15, 2020, 6:31 p.m. UTC | #2
Ryan,

Ryan Prior 写道:
> Tobias, thank you for the quick and thorough review!

I've made up for that now \o/

> I've attached updated patches.

Thanks.  I promise I'll respond to the rest of your mail later 
to(euro-)night.

My ~/guix is a dusty mess from the previous weeks and your 
‘Update’ patch doesn't apply yet.

Kind regards,

T G-R
guix--- via Guix-patches via May 16, 2020, 11:20 a.m. UTC | #3
Ryan Prior 写道:
> [2. text/x-patch; 0001-gnu-oil-Update-to-0.8.pre4.patch]...

Unfortunately I still can't apply this onto upstream/master:

  Applying: gnu: oil: Update to 0.8.pre4
  error: sha1 information is lacking or useless
  (gnu/packages/shells.scm).
  error: could not build fake ancestor
  Patch failed at 0001 gnu: oil: Update to 0.8.pre4

Kind regards,

T G-R
diff mbox series

Patch

From cb72dd3705eb51fa0a5a028443b01af95aff9ca1 Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Fri, 1 May 2020 14:47:20 -0500
Subject: [PATCH] gnu: oil-shell: Rename to "oil" and add a deprecated alias

---
 gnu/packages/shells.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c71e6399ea..10f0ec817c 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -748,9 +748,9 @@  Shell (pdksh).")
     (license (list miros
                    isc))))              ; strlcpy.c
 
-(define-public oil-shell
+(define-public oil
   (package
-    (name "oil-shell")
+    (name "oil")
     (version "0.7.0")
     (source (origin
               (method url-fetch)
@@ -794,6 +794,9 @@  is commonly written.")
     (license (list psfl ; The Oil sources include a patched Python 2 source tree
                    asl2.0))))
 
+(define-public oil-shell
+  (deprecated-package "oil-shell" oil))
+
 (define-public gash
   (package
     (name "gash")
-- 
2.17.1