diff mbox series

[bug#61724,v4,2/7] gnu: nlohmann-json: Update to 3.11.2.

Message ID 7fff809117a7e9a66267143a00b6e927ac96d5be.1683475550.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#61724,v4,1/7] gnu: Rename json-modern-cxx to nlohmann-json. | expand

Commit Message

Liliana Marie Prikler April 28, 2023, 7:50 p.m. UTC
* gnu/packages/cpp.scm (nlohmann-json): Update to 3.11.2.
[source]<snippet>: Adjust accordingly.
[native-inputs]<json_test_data>: Update to 3.1.0.
---
 gnu/packages/cpp.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index a041b4a3bb..5c2e6d2425 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -598,7 +598,7 @@  (define-public json-dto
 (define-public nlohmann-json
   (package
     (name "nlohmann-json")
-    (version "3.10.5")
+    (version "3.11.2")
     (home-page "https://github.com/nlohmann/json")
     (source
      (origin
@@ -606,23 +606,22 @@  (define-public nlohmann-json
        (uri (git-reference (url home-page)
                            (commit (string-append "v" version))))
        (sha256
-        (base32 "1f9mi45ilwjc2w92grjc53sw038840bjpn8yjf6wc6bxs2nijfqd"))
+        (base32 "0g6rfsbkvrxmacchz4kbr741yybj7mls3r4hgyfdd3pdbqhn2is9"))
        (file-name (git-file-name name version))
        (modules '((guix build utils)))
        (snippet
         '(begin
            ;; Delete bundled software.  Preserve doctest_compatibility.h, which
            ;; is a wrapper library added by this package.
-           (install-file "./test/thirdparty/doctest/doctest_compatibility.h" "/tmp")
-           (for-each delete-file-recursively
-                     '("./third_party" "./test/thirdparty"))
-           (install-file "/tmp/doctest_compatibility.h" "./test/thirdparty/doctest")
+           (install-file "./tests/thirdparty/doctest/doctest_compatibility.h" "/tmp")
+           (delete-file-recursively "./tests/thirdparty")
+           (install-file "/tmp/doctest_compatibility.h" "./tests/thirdparty/doctest")
 
            ;; Adjust for the unbundled fifo_map and doctest.
-           (substitute* "./test/thirdparty/doctest/doctest_compatibility.h"
-             (("#include \"doctest\\.h\"")
-              "#include <doctest/doctest.h>"))
-           (with-directory-excursion "test/src"
+           (substitute* (find-files "./tests/" "\\.h(pp)?")
+             (("#include \"doctest\\.h\"") "#include <doctest/doctest.h>")
+             (("#include <doctest\\.h>") "#include <doctest/doctest.h>"))
+           (with-directory-excursion "tests/src"
              (let ((files (find-files "." "\\.cpp$")))
                (substitute* files
                  (("#include ?\"(fifo_map.hpp)\"" all fifo-map-hpp)
@@ -648,7 +647,7 @@  (define-public nlohmann-json
                           (format #t "test suite not run~%")))))))
     (native-inputs
      (list amalgamate
-           (let ((version "3.0.0"))
+           (let ((version "3.1.0"))
              (origin
                (method git-fetch)
                (uri (git-reference
@@ -657,7 +656,7 @@  (define-public nlohmann-json
                (file-name (git-file-name "json_test_data" version))
                (sha256
                 (base32
-                 "0nzsjzlvk14dazwh7k2jb1dinb0pv9jbx5jsyn264wvva0y7daiv"))))))
+                 "0nbirc428qx0lpi940p7y24fzdjbwl6xig3h5rdbihyymmdzhvbc"))))))
     (inputs
      (list doctest fifo-map))
     (synopsis "JSON parser and printer library for C++")