diff mbox series

[bug#72835,qt-team,v2,23/74] gnu: qt-creator: Update to 14.0.1.

Message ID 7f9bb1202d6ff416c5879b6f4affdd6116a441f5.1726567073.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt{5,6}. | expand

Commit Message

Z572 Sept. 18, 2024, 1:43 a.m. UTC
* gnu/packages/qt.scm (qt-creator): Update to 14.0.1.
[source]: Adjust snippet.
[arguments]<#:phases>: adjust patch-paths phase.

Change-Id: Ideafcf3a7c0ce9c85025472d41fb72527cc4b9fb
---
 gnu/packages/qt.scm | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c8fd0ae5c7..83dc8519a9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5558,7 +5558,7 @@  (define-public clazy
 (define-public qt-creator
   (package
     (name "qt-creator")
-    (version "12.0.2")
+    (version "14.0.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -5575,13 +5575,21 @@  (define-public qt-creator
                              ;; Marketplace recommends nonfree extensions;
                              ;; remove it.
                              "src/plugins/marketplace"))
+                          ;; qt-creator installation attempts to install the
+                          ;; yaml-cpp LICENSE file, but we removed the bundled
+                          ;; yaml-cpp, so create an empty file to allow it to
+                          ;; install properly.
+                          (mkdir-p "src/libs/3rdparty/yaml-cpp")
+                          (call-with-output-file "src/libs/3rdparty/yaml-cpp/LICENSE"
+                            (lambda (port)
+                              (const #t)))
                           (substitute* "src/plugins/CMakeLists.txt"
                             (("add_subdirectory\\(marketplace).*") ""))
                           (substitute* "src/plugins/plugins.qbs"
                             ((".*marketplace/marketplace.qbs.*") ""))))
               (sha256
                (base32
-                "1lgk547pvg31zzqra7gn9gsszm5wrwxiw06crbr5n2kqfavk9r22"))))
+                "0zc9z4zzypqd1q49p4ckwbgxqcnnsc11jgsys6wli1ppmvzmn2zn"))))
     (outputs '("out" "debug"))
     (build-system qt-build-system)
     (arguments
@@ -5631,7 +5639,7 @@  (define-public qt-creator
                              "src/libs/utils/deviceshell.cpp")
                 (("/bin/sh")
                  (search-input-file inputs "bin/sh")))
-              (substitute* "src/libs/utils/process.cpp"
+              (substitute* "src/libs/utils/qtcprocess.cpp"
                 (("/usr/bin/env")
                  (search-input-file inputs "bin/env")))
               (substitute* '("tests/auto/utils/process/tst_process.cpp"