[bug#75619,7/7] gnu: retroarch-core-info: Update to 1.20.0.

Message ID 7f465086dffd3f104ff82a193aab7bda593f2e93.1737083128.git.maxim.cournoyer@gmail.com
State New
Headers
Series Add libretro-dolphin-emu and update retroarch |

Commit Message

Maxim Cournoyer Jan. 17, 2025, 4:45 a.m. UTC
  * gnu/packages/emulators.scm (retroarch-core-info): Update to 1.20.0.

Change-Id: I85eec43eedf24df44b5d486a2410652ad87536db
---
 gnu/packages/emulators.scm | 42 ++++++++++++++++++--------------------
 1 file changed, 20 insertions(+), 22 deletions(-)
  

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 88de3dbd8a..37637fc345 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1780,30 +1780,28 @@  (define-public retroarch-assets
 
 (define-public retroarch-core-info
   ;; Use the latest commit, to get recent additions such as bsnes-jg.
-  (let ((commit "c0e7b76d02504754de67a1318f93089f1e29f15f")
-        (revision "0"))
-    (package
-      (name "retroarch-core-info")
-      (version (git-version "1.19.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/libretro/libretro-core-info")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "11xpy3zhy2smp4a70fc0r1b76mvmjyabkaaipifsxm3j25drki5z"))))
-      (build-system copy-build-system)
-      (arguments
-       (list #:install-plan #~'(("." "lib/libretro/"
-                                 #:include-regexp ("\\.info$")))))
-      (home-page "https://github.com/libretro/libretro-core-info")
-      (synopsis "Libretro core info files")
-      (description "This is a versioned snapshot of the files containing
+  (package
+    (name "retroarch-core-info")
+    (version "1.20.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/libretro/libretro-core-info")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rfvp0lkv99jgpfyb9pp6vrh1i1974p3lckh93y1bibdizyxmwjg"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:install-plan #~'(("." "lib/libretro/"
+                               #:include-regexp ("\\.info$")))))
+    (home-page "https://github.com/libretro/libretro-core-info")
+    (synopsis "Libretro core info files")
+    (description "This is a versioned snapshot of the files containing
 metadata about each known libretro core.  The snapshot is taken from the
 @url{https://github.com/libretro/libretro-super, libretro-super} repository.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public retroarch-joypad-autoconfig
   (package