diff mbox series

[bug#66467,1/2] gnu: python-doit: Update to 0.36.0.

Message ID 7eb92ee649dfc77ba26f329b3f70b514aa333018.1697046734.git.paul@apatience.com
State New
Headers show
Series [bug#66467,1/2] gnu: python-doit: Update to 0.36.0. | expand

Commit Message

Paul A. Patience Oct. 11, 2023, 5:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-doit): Update to 0.36.0.
[arguments]: New field.
[propagated-inputs]: Move below native-inputs. Remove python-pyinotify
and add python-importlib-metadata and python-tomli.
[description]: Fix typos and use @code.
---
 gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++++++-------------
 1 file changed, 25 insertions(+), 14 deletions(-)


base-commit: f4e8baf3806e79d7111d2943859865ae4ee0b59d
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 94e8db934f..00129bd442 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32033,28 +32033,39 @@  (define-public python-yapsy
 (define-public python-doit
   (package
     (name "python-doit")
-    (version "0.34.0")
+    (version "0.36.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "doit" version))
-        (sha256
-          (base32 "0bf0m9n0hyjvjpv051zd26725j8jr23gyvc37v3kkadwbh8dxwcf"))))
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "doit" version))
+       (sha256
+        (base32 "1g1lwaxb9q3a6c24sr3gw5bspsk5frbrk2frb7z25jqljp67rl3i"))))
     (build-system python-build-system)
-    (propagated-inputs
-      (list python-cloudpickle python-pyinotify))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "pytest" "-vv" "-k"
+                             ;; Requires doitpy, which is missing from Guix.
+                             "not test_execute")))))))
     (native-inputs
-      (list python-pytest))
+     (list python-pytest))
+    (propagated-inputs
+     (list python-cloudpickle
+           python-importlib-metadata
+           python-tomli))
     (home-page "https://pydoit.org")
     (synopsis "Automation tool to execute any kind of task in a build-tools
 fashion")
-    (description "doit is an automation tool that brings the power of
-build-tools to execute any kind of task.
+    (description "@code{doit} is an automation tool that brings the power of
+build tools to execute any kind of task.
 
 A task describes some computation to be done (actions), and contains some
-extra meta-data.  The actions can be external programs or Python functions.  A
-single task may define more than one action.doit uses the task’s meta-data
-to:
+extra metadata.  The actions can be external programs or Python functions.  A
+single task may define more than one action.  @code{doit} uses the task’s
+metadata to:
 
 @itemize
 @item cache task results