[bug#75503,v2,3/3] gnu: Add partitionmanager.

Message ID 7e259aac89cebc2d2bffa4d061cc3d136a9ea549.1736672077.git.sughosha@disroot.org
State New
Headers
Series gnu: Add partitionmanager |

Commit Message

Sughosha Jan. 12, 2025, 8:54 a.m. UTC
  * gnu/packages/kde.scm (partitionmanager): New variable.

Change-Id: I90e712d47a53b179deced9c704d73d0f41b25071
---
 gnu/packages/kde.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
  

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 7c02de246a..b09381fa6c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1312,6 +1312,45 @@  (define-public kpmcore
     (description "Library for managing partitions.")
     (license license:gpl3+)))
 
+(define-public partitionmanager
+  (package
+    (name "partitionmanager")
+    (version "24.05.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/partitionmanager-" version ".tar.xz"))
+       (sha256
+        (base32 "01xmwkwv8jrwx2jpg797ar8ac9gbdagrl2v3yzqn62fhwcwjcxy6"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:qtbase qtbase))
+    (native-inputs
+     (list extra-cmake-modules kdoctools))
+    (inputs
+     (list kconfig
+           kconfigwidgets
+           kcoreaddons
+           kcrash
+           kdbusaddons
+           ki18n
+           kio
+           kjobwidgets
+           kpmcore
+           kwidgetsaddons
+           kwindowsystem
+           kxmlgui
+           polkit-qt6))
+    (home-page "https://apps.kde.org/partitionmanager/")
+    (synopsis "Disk device, partition and file system manager")
+    (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems.  It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data.  It
+supports a large number of file systems, including ext2/3/4, btrfs, NTFS,
+FAT16/32, JFS, XFS and more.")
+    (license license:gpl3+)))
+
 (define-public kpublictransport
   (package
     (name "kpublictransport")