[bug#78322] gnu: Add python-pytest-pylint.
Commit Message
* gnu/packages/check.scm (python-pytest-pylint): New variable.
Change-Id: Iba326a6fc9cbd333eb63edf2ed61dca45cdf2bc9
---
gnu/packages/check.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
@@ -3105,6 +3105,26 @@ (define-public python-pytest-perf
each of the environments.")
(license license:expat)))
+(define-public python-pytest-pylint
+ (package
+ (name "python-pytest-pylint")
+ (version "0.21.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-pylint" version))
+ (sha256
+ (base32 "0gjm9qy1rsngvli042szqc45y0q5zk1crq28ja01iyjw3n74nxl8"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pylint))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/carsongee/pytest-pylint")
+ (synopsis "Pytest plugin to check source code with Pylint")
+ (description
+ "This plugin allows running Pylint with Pytest and have
+configurable rule types (i.e. Convention, Warn, and Error) fail the build.")
+ (license license:expat)))
+
(define-public python-pytest-flakes
(package
(name "python-pytest-flakes")