diff mbox series

[bug#34393] Notice

Message ID 7debf6baea2c012f2ce37ae46aef9821@hyper.dev
State Accepted
Headers show
Series [bug#34393] Notice | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amirouche May 1, 2019, 11:04 a.m. UTC
On 2019-05-01 03:14, amirouche@hyper.dev wrote:
> I just noticed your comments. I will work on them tomorrow.

Here is a new patch.

This is a fork of the upstream package which add truecolor support.
diff mbox series

Patch

From 64fb39c1d1d436eb6b044238ce3177844bdb39bc Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche+dev@hyper.dev>
Date: Wed, 1 May 2019 12:59:53 +0200
Subject: [PATCH] gnu: add termbox-truecolor

* gnu/packages/terminals.scm (termbox-truecolor): New variable.
---
 gnu/packages/terminals.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index d0531b0c14..79759126ad 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018, 2019 Amirouche Boubekki <amirouche@hyper.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,6 +38,7 @@ 
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system waf)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
@@ -888,6 +890,32 @@  per-line fullscreen terminal rendering, and keyboard input event reporting.")
 (define-public python2-curtsies
   (package-with-python2 python-curtsies))
 
+(define-public termbox-truecolor
+  (let ((commit "962a3d8bee04df75c47187a9910464718ea840aa")
+        (revision "0"))
+    (package
+      (name "termbox-truecolor")
+      (version (git-version "1.1.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/amirouche/termbox-truecolor.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0jkwczx7l36jrp11sp9yrhvgafg811ksxs7vl4ln7k6bw85qmm81"))))
+      (build-system waf-build-system)
+      (arguments
+       `(#:tests? #f)) ;; no tests
+      (synopsis "Text-based user interfaces library")
+      (description "Termbox is a library that provides a minimalistic
+API which allows the programmer to write text-based user interfaces with
+true-color support.  It is based on a simple abstraction: viewing terminals as
+a table of fixed-size cells and input being a stream of structured messages.")
+      (home-page "https://github.com/amirouche/termbox-truecolor/")
+      (license license:expat))))
+
 (define-public tmate
   (package
     (name "tmate")
-- 
2.19.1