[bug#76746,v2,04/13] gnu: Add python-websockets-14.

Message ID 7de4d9f45987adb95816904f78577f3fdaa23664.1741702572.git.45mg.writes@gmail.com
State New
Headers
Series None |

Commit Message

45mg March 11, 2025, 2:23 p.m. UTC
  * gnu/packages/python-web.scm (python-websockets-14): New
variable. Inherits from python-websockets, with the following changes:
[source]{uri}: Use new GitHub repository.
[home-page]: Likewise.
(python-websockets): Inherit from python-websockets-14.

Change-Id: I91b90bf4e407f6726b0ea1b95b7a69f1bd9471ec
---
 gnu/packages/python-web.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0b0428485b..ac3ee99609 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8011,6 +8011,23 @@  (define-public python-websockets
 it provides an elegant coroutine-based API.")
     (license license:bsd-3)))
 
+(define-public python-websockets-14
+  (package
+    (inherit python-websockets)
+    (name "python-websockets")
+    (version "14.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/python-websockets/websockets")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0j8x1xn3m1jcghwy42y6ibspr9kwazcgdz1c90i0jxdgj50xxbiz"))))
+    (home-page "https://github.com/python-websockets/websockets")))
+
 (define-public python-selenium
   (package
     (name "python-selenium")