[bug#76854,5/7] gnu: Add rust-ansi-to-html-0.2.
Commit Message
Change-Id: Ib27771b495d185d2fb67280ee5d10bb70acfb510
---
gnu/packages/crates-io.scm | 33 ++++++++++++++++++++++++++-------
1 file changed, 26 insertions(+), 7 deletions(-)
@@ -1806,8 +1806,33 @@ (define-public rust-ansi-str-0.8
with ANSI strings.")
(license license:expat)))
+(define-public rust-ansi-to-html-0.2
+ (package
+ (name "rust-ansi-to-html")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ansi-to-html" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0r07skcd0rp4fwww66hn2sal4f7p4nhq2zjpk7pkamr8zjj87qhj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-regex" ,rust-regex-1))
+ #:cargo-development-inputs (("rust-divan" ,rust-divan-0.1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-insta" ,rust-insta-1))))
+ (home-page
+ "https://github.com/Aloso/to-html/tree/master/crates/ansi-to-html")
+ (synopsis "ANSI escape codes to HTML converter")
+ (description
+ "This package provides an ANSI escape codes to HTML converter.")
+ (license license:expat)))
+
(define-public rust-ansi-to-html-0.1
(package
+ (inherit rust-ansi-to-html-0.2)
(name "rust-ansi-to-html")
(version "0.1.3")
(source
@@ -1817,17 +1842,11 @@ (define-public rust-ansi-to-html-0.1
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "18kwlgr3vfsij8gvl7vxw11yl628b1s8z2pldh73z4zzq2693gf7"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-once-cell" ,rust-once-cell-1)
("rust-regex" ,rust-regex-1)
("rust-thiserror" ,rust-thiserror-1))
- #:cargo-development-inputs (("rust-insta" ,rust-insta-1))))
- (home-page
- "https://github.com/Aloso/to-html/tree/master/crates/ansi-to-html")
- (synopsis "ANSI escape codes to HTML converter")
- (description "This package provides an ANSI escape codes to HTML converter.")
- (license license:expat)))
+ #:cargo-development-inputs (("rust-insta" ,rust-insta-1))))))
(define-public rust-ansi-width-0.1
(package