[bug#77764,v2] gnu: Add emacs-jira.

Message ID 7ddb2fa12dcb94651c1ddf50c9695f97e3f9db4d.1744531156.git.roman@burningswell.com
State New
Headers
Series [bug#77764,v2] gnu: Add emacs-jira. |

Commit Message

Roman Scherer April 13, 2025, 8 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-jira): New variable.

Change-Id: I7846eeea3f4f9c06f75d768c7264656a69afdd96
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 63f323fc98fb6e85c48721574aab8e54d95091e5
  

Comments

Liliana Marie Prikler April 13, 2025, 3:32 p.m. UTC | #1
Am Sonntag, dem 13.04.2025 um 10:00 +0200 schrieb Roman Scherer:
> * gnu/packages/emacs-xyz.scm (emacs-jira): New variable.
> 
> Change-Id: I7846eeea3f4f9c06f75d768c7264656a69afdd96
> ---
>  gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index b290ab8d29..55ef037881 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -12277,6 +12277,31 @@ (define-public emacs-jedi
>  the locations of docstrings, arguments, and functions.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-jira
> +  (package
> +    (name "emacs-jira")
> +    (version "0.7.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/unmonoqueteclea/jira.el")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> "0zg7qx05i92xpsa43y9gsxbn08gmzng88dvkva7y70zvrzx58zz2"))))
> +    (build-system emacs-build-system)
> +    (arguments (list #:tests? #f))
Cayetano did tell you to put #:tests? #f here, but you should also give
a reason as to why tests are disabled – such as the "; no tests"
Cayetano wrote.
> +    (propagated-inputs (list emacs-magit
> +                             emacs-request
> +                             emacs-tablist
> +                             emacs-transient))
> +    (home-page "https://github.com/unmonoqueteclea/jira.el")
> +    (synopsis "Emacs Interface to Jira")
> +    (description "This package allows you to visualuze and
> manipulate Jira
> +issues from Emacs.")
> +    (license license:gpl3+)))
> +
>  (define-public emacs-company-jedi
>    (package
>      (name "emacs-company-jedi")
Cheers
  
Roman Scherer April 14, 2025, 7:26 a.m. UTC | #2
References: <8f93ddee259d0ecd5323cf6c7ce3356a2dfd5e1d.1744464248.git.roman@burningswell.com>
	<7ddb2fa12dcb94651c1ddf50c9695f97e3f9db4d.1744531156.git.roman@burningswell.com>
	<6a02e12e0f88de11f8cb51404aba868b2c0722ff.camel@gmail.com>
User-Agent: mu4e 1.12.9; emacs 29.4
Hi Liliana,

thanks for the review. I added the missing comment and sent a v3.

Can you have another look please?

Thanks, Roman.

Date: Mon, 14 Apr 2025 09:26:38 +0200

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 13.04.2025 um 10:00 +0200 schrieb Roman Scherer:
>> * gnu/packages/emacs-xyz.scm (emacs-jira): New variable.
>>
>> Change-Id: I7846eeea3f4f9c06f75d768c7264656a69afdd96
>> ---
>>  gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
>>  1 file changed, 25 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index b290ab8d29..55ef037881 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -12277,6 +12277,31 @@ (define-public emacs-jedi
>>  the locations of docstrings, arguments, and functions.")
>>      (license license:gpl3+)))
>>
>> +(define-public emacs-jira
>> +  (package
>> +    (name "emacs-jira")
>> +    (version "0.7.0")
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/unmonoqueteclea/jira.el")
>> +             (commit (string-append "v" version))))
>> +       (file-name (git-file-name name version))
>> +       (sha256
>> +        (base32
>> "0zg7qx05i92xpsa43y9gsxbn08gmzng88dvkva7y70zvrzx58zz2"))))
>> +    (build-system emacs-build-system)
>> +    (arguments (list #:tests? #f))
> Cayetano did tell you to put #:tests? #f here, but you should also give
> a reason as to why tests are disabled – such as the "; no tests"
> Cayetano wrote.
>> +    (propagated-inputs (list emacs-magit
>> +                             emacs-request
>> +                             emacs-tablist
>> +                             emacs-transient))
>> +    (home-page "https://github.com/unmonoqueteclea/jira.el")
>> +    (synopsis "Emacs Interface to Jira")
>> +    (description "This package allows you to visualuze and
>> manipulate Jira
>> +issues from Emacs.")
>> +    (license license:gpl3+)))
>> +
>>  (define-public emacs-company-jedi
>>    (package
>>      (name "emacs-company-jedi")
> Cheers
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b290ab8d29..55ef037881 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12277,6 +12277,31 @@  (define-public emacs-jedi
 the locations of docstrings, arguments, and functions.")
     (license license:gpl3+)))
 
+(define-public emacs-jira
+  (package
+    (name "emacs-jira")
+    (version "0.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/unmonoqueteclea/jira.el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zg7qx05i92xpsa43y9gsxbn08gmzng88dvkva7y70zvrzx58zz2"))))
+    (build-system emacs-build-system)
+    (arguments (list #:tests? #f))
+    (propagated-inputs (list emacs-magit
+                             emacs-request
+                             emacs-tablist
+                             emacs-transient))
+    (home-page "https://github.com/unmonoqueteclea/jira.el")
+    (synopsis "Emacs Interface to Jira")
+    (description "This package allows you to visualuze and manipulate Jira
+issues from Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-company-jedi
   (package
     (name "emacs-company-jedi")