diff mbox series

[bug#73073,v2,3/8] gnu: dmd-bootstrap: Move phobos origin from phases to native-inputs.

Message ID 7d8122f6519b77f5accf4f83ee03169ad03ad7b1.1725930587.git.zimon.toutoune@gmail.com
State New
Headers show
Series Allow origin inside inputs with "new style". | expand

Commit Message

Simon Tournier Sept. 10, 2024, 1:27 a.m. UTC
* gnu/packages/dlang.scm (dmd-bootstrap)[arguments]<phases>: Move phobos
origin from here...
[native-inputs]: ...to here.

Change-Id: I10cb5f628dad2fdbb01df58134996bdcd0b73d62
---
 gnu/packages/dlang.scm | 21 +++++++++++----------
 1 file changed, 11 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 8bf0ee685e..1fd1c8d58c 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -456,15 +456,7 @@  (define dmd-bootstrap
             (lambda _
               (symlink "." "dmd")  ;to please the build system expected layout
               (copy-recursively
-               #$(origin
-                   (method git-fetch)
-                   (uri (git-reference
-                         (url "https://github.com/dlang/phobos")
-                         (commit (string-append "v" version))))
-                   (file-name (git-file-name "phobos" version))
-                   (sha256
-                    (base32
-                     "1yw7nb5d78cx9m7sfibv7rfc7wj3w0dw9mfk3d269qpfpnwzs4n9")))
+               #$(this-package-native-input (git-file-name "phobos" version))
                "phobos")
               (chdir "phobos")))
           (add-after 'copy-phobos-source-and-chdir 'adjust-phobos-install-dirs
@@ -519,7 +511,16 @@  (define dmd-bootstrap
                  "lib")
                 (("\\.\\./src/(phobos|druntime/import)")
                  "include/dmd")))))))
-    (native-inputs (list gdmd which))
+    (native-inputs (list gdmd which
+                         (origin
+                           (method git-fetch)
+                           (uri (git-reference
+                                 (url "https://github.com/dlang/phobos")
+                                 (commit (string-append "v" version))))
+                           (file-name (git-file-name "phobos" version))
+                           (sha256
+                            (base32
+                             "1yw7nb5d78cx9m7sfibv7rfc7wj3w0dw9mfk3d269qpfpnwzs4n9")))))
     (home-page "https://github.com/dlang/dmd")
     (synopsis "Reference D Programming Language compiler")
     (description "@acronym{DMD, Digital Mars D compiler} is the reference