diff mbox series

[bug#52278,v2,1/3] gnu: Add xiph-rnnoise.

Message ID 7d67d79484cb9f452144c195032af906d7ced37b.camel@gmail.com
State Accepted
Headers show
Series [bug#52278,v2,1/3] gnu: Add xiph-rnnoise. | expand

Commit Message

Liliana Marie Prikler Dec. 4, 2021, 1:39 p.m. UTC
* gnu/packages/xiph.scm (xiph-rnnoise): New variable.
---
 gnu/packages/xiph.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 0c9c799067..be94dcce09 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -513,3 +513,36 @@  (define-public libshout
 icecast server.  It handles the socket connection, the timing of the data,
 and prevents bad data from getting to the icecast server.")
     (license license:gpl2+)))
+
+(define-public xiph-rnnoise
+  ;; No upstream release
+  (let ((commit "7f449bf8bd3b933891d12c30112268c4090e4d59")
+        (revision "0"))
+   (package
+     (name "rnnoise")
+     (version (git-version "0" revision commit))
+     (source (origin
+               (method git-fetch)
+               (uri (git-reference
+                     (url "https://gitlab.xiph.org/xiph/rnnoise")
+                     (commit commit)))
+               (file-name (git-file-name name version))
+               (sha256
+                (base32
+                 "0y8jdvxd9namw4f9hcmcmm2q0f32mnhfyjap8906hl308cws3rkj"))))
+     (build-system gnu-build-system)
+     (native-inputs
+      `(("autoconf" ,autoconf)
+        ("automake" ,automake)
+        ("libtool" ,libtool)))
+     (home-page "https://gitlab.xiph.org/xiph/rnnoise")
+     (synopsis "Real-time noise suppression")
+     (description "RNNoise is a noise suppression library based on a recurrent
+neural network.  The algorithm is described in Jean-Marc Valin's paper
+@cite{A Hybrid DSP/Deep Learning Approach to Real-Time Full-Band Speech
+Enhancement}.")
+     (license license:bsd-3)
+     (properties
+      ;; There's no public release and a conflicting package, so hide it for
+      ;; now.
+      `((hidden? . #t))))))