diff mbox series

[bug#67277] gnu: Add vim-srcery.

Message ID 7d15dc8b19c276d128accc3c6940a954f2bafbe9.1700396376.git.mcsinyx@disroot.org
State New
Headers show
Series [bug#67277] gnu: Add vim-srcery. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Nov. 19, 2023, 12:19 p.m. UTC
* gnu/packages/vim.scm (vim-srcery): New variable.

Change-Id: If53bdae6783af5500f517c4941babb3bdb6522e7
---
 gnu/packages/vim.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 5cad6f721b8884b612178896f06cd69d5839402c

Comments

Efraim Flashner Nov. 26, 2023, 10:10 a.m. UTC | #1
Thanks for the patch. I moved it to opt as recommended by the
documentation.  I also renamed the package to vim-srcery-vim.
vasilii.smirnov--- via Guix-patches" via Nov. 27, 2023, 4:02 p.m. UTC | #2
On 2023-11-26 at 12:10+02:00, Efraim Flashner wrote:
> Thanks for the patch. I moved it to opt as recommended by the
> documentation.  I also renamed the package to vim-srcery-vim.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 469c8b64cbe6..5e9397177039 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022, 2023 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
 ;;; Copyright © 2023 Charles Jackson <charles.b.jackson@protonmail.com>
+;;; Copyright © 2023 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1423,3 +1424,25 @@  (define-public vim-nerdcommenter
 operations and styles which are invoked via key mappings and a menu.  These
 operations are available for most filetypes.")
     (license license:cc0)))
+
+(define-public vim-srcery
+  (package
+    (name "vim-srcery")
+    (version "2.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/srcery-colors/srcery-vim")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0nwk81y9j5ljjm3k19kf1zmscdxiis4mwan026wv7cqp7f9qhxlr"))))
+    (build-system vim-build-system)
+    (arguments (list #:plugin-name "srcery"))
+    (home-page "https://srcery.sh")
+    (synopsis "Dark colorscheme for gvim and vim")
+    (description
+      "Srcery is a color scheme with clearly defined contrasting colors
+and a slightly earthy tone.")
+    (license license:expat)))