diff mbox series

[bug#69736,v2,4/6] gnu: Add python-enlighten.

Message ID 7cf7aff610bfbcfeac9dfc4374fc380962b7916e.1720019008.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#69736,v2,1/6] gnu: Add python-pypubsub. | expand

Commit Message

Arun Isaac July 3, 2024, 3:07 p.m. UTC
* gnu/packages/python-xyz.scm (python-enlighten): New variable.

Change-Id: Ifcc1e71cf012eb3b7e2c0ceef7d288cea9fa6a91
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 993e0e0f6b..8982813479 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18639,6 +18639,28 @@  (define-public python-progressbar33
     ;; Either or both of these licenses may be selected.
     (license (list license:lgpl2.1+ license:bsd-3))))
 
+(define-public python-enlighten
+  (package
+    (name "python-enlighten")
+    (version "1.12.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "enlighten" version))
+              (sha256
+               (base32
+                "0psvglhi0c7d7pdk9rfb8scnv3xbq2fz78619x2mxvz094mxkwvm"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-blessed python-prefixed))
+    (home-page "https://github.com/Rockhopper-Technologies/enlighten")
+    (synopsis "Console progress bar library")
+    (description "@code{python-enlighten} is a console progress bar library
+for Python.  The main advantage of Enlighten is that it allows writing to
+stdout and stderr without any redirection or additional code---just print or
+log as you normally would.  Enlighten also includes experimental support for
+Jupyter Notebooks.")
+    (license license:mpl2.0)))
+
 (define-public python-colorama
   (package
    (name "python-colorama")