diff mbox series

[bug#70276] gnu: python-deeptools: Update to 3.5.5.

Message ID 7ce52e967f67a161bbfc172e6494863a3355f8ab.1712580113.git.zimon.toutoune@gmail.com
State New
Headers show
Series [bug#70276] gnu: python-deeptools: Update to 3.5.5. | expand

Commit Message

Simon Tournier April 8, 2024, 12:49 p.m. UTC
* gnu/packages/bioinformatics.scm (python-deeptools): Update to 3.5.5.
[build-system]: Replace by pyproject-build-system.
[arguments]: Add phase that fixes 'test/test_tools.py'.

Change-Id: Ibb51939275c96df2c4a1e248a03d683f2f4904ac
---
 gnu/packages/bioinformatics.scm | 23 +++++++++++++++++++----
 1 file changed, 19 insertions(+), 4 deletions(-)


base-commit: cd45294d576975a3bff2f755764a3f46f09ea6f9

Comments

Christopher Baines April 9, 2024, 5:15 p.m. UTC | #1
Simon Tournier <zimon.toutoune@gmail.com> writes:

> * gnu/packages/bioinformatics.scm (python-deeptools): Update to 3.5.5.
> [build-system]: Replace by pyproject-build-system.
> [arguments]: Add phase that fixes 'test/test_tools.py'.
>
> Change-Id: Ibb51939275c96df2c4a1e248a03d683f2f4904ac
> ---
>  gnu/packages/bioinformatics.scm | 23 +++++++++++++++++++----
>  1 file changed, 19 insertions(+), 4 deletions(-)

Looks good to me, I've pushed this to master as
cf29c427e90bd82556addf67885c276e067ce121.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7861987704..452ec1d829 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4615,7 +4615,7 @@  (define-public python-deeptoolsintervals
 (define-public python-deeptools
   (package
     (name "python-deeptools")
-    (version "3.4.3")
+    (version "3.5.5")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4624,8 +4624,23 @@  (define-public python-deeptools
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0l09vyynz6s6w7fnyd94rpys4a6aja6kp4gli64pngdxdz3md1nl"))))
-    (build-system python-build-system)
+                "0mgcs03amrd5157drbm6ikdg0m0szrn9xbflariz2zrrnqpsai6s"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-test
+            (lambda _
+              (substitute* "deeptools/test/test_tools.py"
+                (("e_ver = _p")
+                 "e_ver = \".\" + _p + \"-real\""))
+              (substitute* "deeptools/multiBigwigSummary.py"
+                (("version='multiBigwigSummary")
+                 "version='%(prog)s"))
+              (substitute* "deeptools/plotCoverage.py"
+                (("version='plotCoverage")
+                 "version='%(prog)s")))))))
     (native-inputs
      (list python-mock python-nose))
     (propagated-inputs
@@ -4637,7 +4652,7 @@  (define-public python-deeptools
            python-pysam
            python-scipy
            python-deeptoolsintervals
-           python-plotly-2.4.1))
+           python-plotly))
     (home-page "https://pypi.org/project/deepTools/")
     (synopsis "Useful tools for exploring deep sequencing data")
     (description "This package addresses the challenge of handling large amounts