diff mbox series

[bug#59648] gnu: icedove: Use native notifications when available

Message ID 7cc35b95103dd43472eb68b810971060e35aa42b.1669611249.git.seerlite@nixnet.email
State New
Headers show
Series [bug#59648] gnu: icedove: Use native notifications when available | expand

Commit Message

SeerLite Nov. 28, 2022, 4:54 a.m. UTC
* gnu/packages/gnuzilla.scm (icedove)[phases]{wrap-program}: Add libnotify
to LD_LIBRARY_PATH.
---
 gnu/packages/gnuzilla.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Dec. 5, 2022, 4:17 p.m. UTC | #1
Hi,

SeerLite <seerlite@nixnet.email> skribis:

> * gnu/packages/gnuzilla.scm (icedove)[phases]{wrap-program}: Add libnotify
> to LD_LIBRARY_PATH.

Jonathan: this one’s for you.  :-)

Ludo’.
Jonathan Brielmaier Dec. 8, 2022, 3:09 p.m. UTC | #2
Hello SeerNet,

hm, when I enable notifications in Thunderbird I get notifications from
my sway desktop:
I just enabled it via Settings -> General -> Incoming Messages -> When
new messages arrive -> [x] Show an alert.

This is without your patch applied...

~Jonathan
SeerLite Feb. 19, 2023, 1:39 a.m. UTC | #3
Hi! Sorry, I didn't receive this response when it was sent, and it 
wasn't in my inbox.

> Hello SeerNet,

It's SeerLite :s

> hm, when I enable notifications in Thunderbird I get notifications from
> my sway desktop:
> I just enabled it via Settings -> General -> Incoming Messages -> When
> new messages arrive -> [x] Show an alert.
> 
> This is without your patch applied...

Yes, that's the same for me as well. The issue is not that there aren't 
notifications, but that IceDove chooses to use its own fallback 
implementation of them rather than using the program configured to send 
them (in my case it's dunst). Without my patch I get large notifications 
inconsistent with my setup. With my patch I get my custom configured 
dunst notifications.

I'm pretty sure Icecat would use the same fallback notification 
implementation if it didn't have libnotify. That's how I found out about 
this issue back when I made the patch after all, but I can't remember 
the details anymore. All I can say is Icedove uses the right 
notifications on my machine with the patch applied.

I hope that explains the difference and maybe you're able to reproduce 
the issue.

PS: I was actually actively waiting for a response since I sent the 
patch (same as my other patch). Unfortunately I didn't check mumi 
earlier. I've also changed my E-mail provider as the server I was 
previously using was having a hard time getting to Debbugs.
Jonathan Brielmaier April 12, 2023, 8:34 a.m. UTC | #4
Hello SeerLite,

rebased and pushed as a3239ffd84e6ee9d9494085ddc3b875ebf43e225.

~Jonathan
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index feb80d81a2..6a8ee41a1e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1189,6 +1189,7 @@  (define (runpaths-of-input label)
                                         "eudev"
                                         "pulseaudio"
                                         ;; For the integration of native notifications
+                                        ;; (same reason as icedove)
                                         "libnotify"))))
                 (wrap-program (car (find-files lib "^icecat$"))
                   `("XDG_DATA_DIRS" prefix (,gtk-share))
@@ -1496,10 +1497,13 @@  (define-public icedove
                      (pulseaudio #$(this-package-input "pulseaudio"))
                      (pulseaudio-lib (string-append pulseaudio "/lib"))
                      (eudev #$(this-package-input "eudev"))
-                     (eudev-lib (string-append eudev "/lib")))
+                     (eudev-lib (string-append eudev "/lib"))
+                     ;; For the integration of native notifications (same reason as icecat)
+                     (libnotify #$(this-package-input "libnotify"))
+                     (libnotify-lib (string-append libnotify "/lib")))
                 (wrap-program (car (find-files lib "^icedove$"))
                   `("XDG_DATA_DIRS" prefix (,gtk-share))
-                  `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))))))))
+                  `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib ,libnotify-lib)))))))))
     (inputs
      (list alsa-lib
            bzip2
@@ -1519,6 +1523,7 @@  (define-public icedove
            libffi
            libgnome
            libjpeg-turbo
+           libnotify
            libpng-apng
            libvpx
            libxcomposite