diff mbox series

[bug#39784] Add zlfo.

Message ID 7c9f720c38ca4b0286c3c543341936d546dd2820.camel@zrythm.org
State Accepted
Headers show
Series [bug#39784] Add zlfo. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 21, 2020, 6:50 p.m. UTC
Hi,

Thanks for the feedback.

Just updated the patches (see attachment).

Thanks,
Alex

Comments

Maja Kądziołka March 23, 2020, 2:45 p.m. UTC | #1
Thanks for your updated patches! You still haven't ran indent-code.el on
them, but I fixed that on my side. I also took the liberty to define the
inputs of ztoolkit-rsvg in terms of the ztoolkit package, like this:

@@ -4119,7 +4119,6 @@ minimum.")
     (arguments
      `(#:configure-flags `("-Denable_rsvg=true")))
     (inputs
-     `(("cairo" ,cairo)
-       ("librsvg" ,librsvg)
-       ("libx11" ,libx11)))
+     `(("librsvg" ,librsvg)
+       ,@(package-inputs ztoolkit)))
     (synopsis "ZToolkit with SVG support")))

Your patches have been applied on master, with the last commit being
d3e7282ec35d87842e8143f0230e27fd5ec5e74d

Cheers!
diff mbox series

Patch

From f9398e031b8f88fb0cd7be7f9aa63cfd3bc1e825 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 18:44:13 +0000
Subject: [PATCH 1/3] gnu: Add ztoolkit.

* gnu/packages/audio.scm (ztoolkit): New variable.
---
 gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f3edd21c69..fe951b5153 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4081,3 +4081,33 @@  given plugin and its UI(s) match up with the provided metadata and adhere
 to well-known best practices.")
     (home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
     (license license:artistic2.0)))
+
+(define-public ztoolkit
+  (package
+    (name "ztoolkit")
+    (version "0.1.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://git.zrythm.org/git/ztoolkit")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("cairo" ,cairo)
+       ("libx11" ,libx11)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "GUI toolkit for LV2 plugins")
+    (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
+inspired by GTK.  It handles events and low level drawing on behalf of
+the user and provides a high-level API for managing the UI and custom
+widgets.  ZToolkit is written in C and was created to be used for building
+audio plugin UIs, where the dependencies often need to be kept to a
+minimum.")
+    (home-page "https://git.zrythm.org/cgit/ztoolkit/")
+    (license license:agpl3+)))
-- 
2.25.1