[bug#67274,v1] gnu: Add emacs-font-utils.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-font-utils): New variable.
Change-Id: Ia9f61f07dc1d2d6955dcda46d786d6c75f971539
---
Fix, update to recent guix and minor changes to previous patch.
Items marked as checked:
- Commit messages
- Package builds
- Lint warnings
- Package style
- No dependent packages build
- Licenses
- Synopsis and descriptions
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
base-commit: ab0b6e920f805d65255318ed0ea4466ec0ebcee6
--
2.48.1
@@ -5826,6 +5826,31 @@ (define-public emacs-font-lock-studio
the Font Lock keywords.")
(license license:gpl3+)))
+(define-public emacs-font-utils
+ ;; latest release from 10 years ago
+ (let ((commit "abc572eb0dc30a26584c0058c3fe6c7273a10003")
+ (revision "0"))
+ (package
+ (name "emacs-font-utils")
+ (version (git-version "0.7.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rolandwalker/font-utils/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hx3k2zx2kdavivr1b957jq7kcwk301yzw77aprxzbs7jz73a35x"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rolandwalker/font-utils/")
+ (synopsis "Utility functions for working with fonts in Emacs")
+ (description
+ "@code{Font-utils} is a collection of functions for working with fonts. This
+library has no user-level interface, it is only useful for programming in Emacs
+Lisp.")
+ (license license:bsd-2))))
+
(define-public emacs-fontaine
(package
(name "emacs-fontaine")