[bug#76363,v1] gnu: Add python-pytooling.

Message ID 7c796934fae76caba0fd0ae72d430602d95c7038.1740059901.git.csantosb@inventati.org
State New
Headers
Series [bug#76363,v1] gnu: Add python-pytooling. |

Commit Message

Cayetano Santos Feb. 20, 2025, 1:58 p.m. UTC
  * gnu/packages/python-xyz.scm (python-pytooling): New variable.

Change-Id: Id045f071b6c531d4afff4322d1a544589f214d50
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: cd20619cfcb32c2631fb602729512740bc510550
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f626b51c1..e0636151fb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2588,6 +2588,30 @@  (define-public python-pytoolconfig
 configuration file.")
     (license license:lgpl3+)))
 
+(define-public python-pytooling
+  (package
+    (name "python-pytooling")
+    (version "8.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pyTooling/pyTooling/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07mca75d2zd6xl0isf0vrcblsc2niyqi7941dgjpiafnsgiygfzf"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:tests? #f)) ; requires recent versions of mypy and lxml
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://pytooling.github.io/pyTooling/")
+    (synopsis "Miscellaneous python tools")
+    (description
+     "@code{pyTooling} is a collection of arbitrary useful classes,
+decorators, meta-classes and exceptions.")
+    (license license:asl2.0)))
+
 (define-public python-colorlog
   (package
     (name "python-colorlog")