* gnu/packages/gnome.scm (libgweather): Update to 4.4.4.
[#:phases]: Add ‘set-home’.
[native-inputs]: Add gi-docgen.
[inputs]: Add json-glib. Replace libsoup-minimal-2 with libsoup and
geocode-glib-with-libsoup2 with geocode-glib.
---
gnu/packages/gnome.scm | 20 ++++++++++++++------
1 file changed, 14 insertions(+), 6 deletions(-)
@@ -5998,7 +5998,7 @@ (define-public upower
(define-public libgweather
(package
(name "libgweather")
- (version "40.0")
+ (version "4.4.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6006,7 +6006,7 @@ (define-public libgweather
name "-" version ".tar.xz"))
(sha256
(base32
- "1rkf4yv43qcahyx7bismdv6z2vh5azdnm1fqfmnzrada9cm8ykna"))))
+ "10s2pyf96yj287929px8jfbkda7bn76vzr2mqgyx3xydadvnf5vh"))))
(build-system meson-build-system)
(arguments
(list
@@ -6014,11 +6014,18 @@ (define-public libgweather
#:configure-flags
#~(list (string-append "-Dzoneinfo_dir="
(search-input-directory %build-inputs
- "share/zoneinfo")))))
+ "share/zoneinfo")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-home
+ (lambda _
+ ;; Build writes to $HOME via fontconfig.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
(list gettext-minimal
`(,glib "bin") ;for glib-mkenums
gobject-introspection
+ gi-docgen
pkg-config
python
vala
@@ -6028,12 +6035,13 @@ (define-public libgweather
;; libsoup.
(list gtk+
gdk-pixbuf
+ json-glib
libxml2
- libsoup-minimal-2
- geocode-glib-with-libsoup2))
+ libsoup
+ geocode-glib))
(inputs
(list tzdata))
- (home-page "https://wiki.gnome.org/action/show/Projects/LibGWeather")
+ (home-page "https://gnome.pages.gitlab.gnome.org/libgweather/")
(synopsis "Location, time zone, and weather library for GNOME")
(description
"libgweather is a library to access weather information from online