diff mbox series

[bug#69500,v2] gnu: Add emacs-citar-denote.

Message ID 7c3cea0a8e4ab51eb7a1ab1ea8946c2e31fe83a8.1709385599.git.i@dan.games
State New
Headers show
Series [bug#69500,v2] gnu: Add emacs-citar-denote. | expand

Commit Message

dan March 2, 2024, 1:19 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-citar-denote): New variable.

Change-Id: Ib728e5f005f2c6cd84864bb0ecc11c8ed40ac24b
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 4a0549be52f3f46fbce61342d8de30f7b83130c5

Comments

Andrew Tropin March 4, 2024, 2:40 p.m. UTC | #1
On 2024-03-02 21:19, dan wrote:

> * gnu/packages/emacs-xyz.scm (emacs-citar-denote): New variable.
>
> Change-Id: Ib728e5f005f2c6cd84864bb0ecc11c8ed40ac24b
> ---
>  gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index a93165404e..623fa64d0d 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -137,6 +137,7 @@
>  ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
>  ;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
>  ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
> +;;; Copyright © 2024 dan <i@dan.games>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -23841,6 +23842,29 @@ (define-public emacs-citar-org-roam
>  @end itemize")
>      (license license:gpl3+)))
>  
> +(define-public emacs-citar-denote
> +  (package
> +    (name "emacs-citar-denote")
> +    (version "2.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/pprevos/citar-denote")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0g476awbrdws7k7smk1qasz15df20zilx3wqbi3wj0i1q2dbsi8z"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs (list emacs-citar emacs-denote))
> +    (home-page "https://github.com/pprevos/citar-denote")
> +    (synopsis "Emacs package to create and retrieve bibliography notes with
> +the Citar and Denote packages.")
> +    (description
> +     "citar-denote is a minor-mode integrating the Emacs Citar and
> +Denote packages to enable create managing bibliographic notes and citations.")
> +    (license license:gpl3+)))
> +
>  (define-public emacs-helm-bibtex
>    (let ((commit "8ebf50d5bd368082d0b7ab79d26a52f372cdef98")
>          (revision "1"))
>
> base-commit: 4a0549be52f3f46fbce61342d8de30f7b83130c5

Hi Dan!

Applied, adjusted synopsis and description a bit, pushed as
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=9321cf7f51

Thank you for the patch, take a look at lint output next time, pls:
./pre-inst-env guix lint emacs-citar-denote

Have a nice day!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a93165404e..623fa64d0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -137,6 +137,7 @@ 
 ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
 ;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
 ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
+;;; Copyright © 2024 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23841,6 +23842,29 @@  (define-public emacs-citar-org-roam
 @end itemize")
     (license license:gpl3+)))
 
+(define-public emacs-citar-denote
+  (package
+    (name "emacs-citar-denote")
+    (version "2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pprevos/citar-denote")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0g476awbrdws7k7smk1qasz15df20zilx3wqbi3wj0i1q2dbsi8z"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-citar emacs-denote))
+    (home-page "https://github.com/pprevos/citar-denote")
+    (synopsis "Emacs package to create and retrieve bibliography notes with
+the Citar and Denote packages.")
+    (description
+     "citar-denote is a minor-mode integrating the Emacs Citar and
+Denote packages to enable create managing bibliographic notes and citations.")
+    (license license:gpl3+)))
+
 (define-public emacs-helm-bibtex
   (let ((commit "8ebf50d5bd368082d0b7ab79d26a52f372cdef98")
         (revision "1"))