diff mbox series

[bug#70883] gnu: llama-cpp: Update to commit fed010.

Message ID 7c2a1ab89edc065ae01fa817955ec92b8f49b575.1715454561.git.atai@atai.org
State New
Headers show
Series [bug#70883] gnu: llama-cpp: Update to commit fed010. | expand

Commit Message

Andy Tai May 11, 2024, 7:10 p.m. UTC
* gnu/packages/machine-learning.scm (llama-cpp): Update to commit fed010
  as last update was in February and new changes for new models and memory
  leaks fixes since then.
  [arguments]: <#:phases>: Add 'disable-unrunable-tests' phase.

Change-Id: Ia6532945f588747c4d58fdb7611d6a9c3c596705
---
 gnu/packages/machine-learning.scm | 15 ++++++++++++---
 1 file changed, 12 insertions(+), 3 deletions(-)


base-commit: 4eb1a5426b93bfd19282db0d255633ca2959efc5

Comments

Andy Tai May 12, 2024, 9:55 p.m. UTC | #1
patch passes Guix QA

https://qa.guix.gnu.org/issue/70883
Nicolas Graves May 13, 2024, 5:28 a.m. UTC | #2
user guix
usertag 70883 + reviewed-looks-good
thanks

Guix QA review form submission:

Hi Andy,

The trailing #t at the end of the 'disable-unrunable-tests phase is not
necessary, otherwise LGTM.

lint warns about possible upgrade but that's fine. 

Items marked as checked: Lint warnings, Package builds, Commit messages
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 7ff8c098b1..b737707a75 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -524,8 +524,8 @@  (define-public guile-aiscm-next
   (deprecated-package "guile-aiscm-next" guile-aiscm))
 
 (define-public llama-cpp
-  (let ((commit "03bf161eb6dea6400ee49c6dc6b69bdcfa9fd3fc")
-        (revision "1"))
+  (let ((commit "fed0108491a3a3cbec6c6480dc8667ffff9d7659")
+        (revision "2"))
     (package
       (name "llama-cpp")
       (version (git-version "0.0.0" revision commit))
@@ -537,7 +537,7 @@  (define-public llama-cpp
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "1ag1jash84hasz10h0piw72a8ginm8kzvhihbzzljz96gq2kjm88"))))
+          (base32 "16rm9gy0chd6k07crm8rkl2j3hg7y7h0km7k6c8q7bmm2jrd64la"))))
       (build-system cmake-build-system)
       (arguments
        (list
@@ -559,6 +559,15 @@  (define-public llama-cpp
                              (guix build python-build-system))
         #:phases
         #~(modify-phases %standard-phases
+            (add-after 'unpack 'disable-unrunable-tests
+               ; test-eval-callback downloads ML model from network, cannot run
+               ; in Guix build environment
+               (lambda _
+                   (substitute* '("examples/eval-callback/CMakeLists.txt")
+                       (("add_test") "#add_test"))
+                   (substitute* '("examples/eval-callback/CMakeLists.txt")
+                       (("set_property") "#set_property"))
+                   #t))
             (add-before 'install 'install-python-scripts
               (lambda _
                 (let ((bin (string-append #$output "/bin/")))