diff mbox series

[bug#60571,v4,2/3] gnu: skia: Update to 112.0.6d0b938.

Message ID 7c09055bb21809cc4e2d0ad10e1aad600c5eacce.1693926428.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#60571,v4,1/3] gnu: skia: Update to 110.0.0f3fb7a. | expand

Commit Message

Nicolas Graves Sept. 5, 2023, 3:07 p.m. UTC
* gnu/packages/graphics.scm (skia): Update to 112.0.6d0b938.
---
 gnu/packages/graphics.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 2182cdeaf2..24ed547782 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1999,9 +1999,9 @@  (define-public skia
   ;; https://skia.org/docs/user/release/release_notes/.  The commit used
   ;; should be the last commit, as recommended at
   ;; https://skia.org/docs/user/release/.
-  (let ((version "110")
+  (let ((version "112")
         (revision "0")
-        (commit "0f3fb7a005fb357962e8b948ff4ec6b37f11e01b"))
+        (commit "6d0b93856303fcf3021a8b40654d7739fda4dfb0"))
     (package
       (name "skia")
       (version (git-version version revision commit))
@@ -2013,7 +2013,7 @@  (define-public skia
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1aqdnx3817hzhy60mc72j6iwaywvd3b5fj3ffpjxnnras38x2jvp"))))
+                  "0g07xlvpbbxqmr9igvy5d1hy11z7dz9nzp2fd3ka9y2jqciniyz6"))))
       (build-system gnu-build-system)   ;actually GN + Ninja
       (arguments
        (list
@@ -2033,6 +2033,7 @@  (define-public skia
                          "cc=\"gcc\" "              ;defaults to 'cc'
                          "is_official_build=true "  ;to use system libraries
                          "is_component_build=true " ;build as a shared library
+                         "skia_use_system_zlib=true " ; use system zlib library
                          ;; Specify where locate the harfbuzz and freetype
                          ;; includes.
                          (format #f "extra_cflags=[\"-I~a\",\"-I~a\"] "
@@ -2129,6 +2130,7 @@  (define-public skia
                            "skia_use_perfetto=false " ; disable performance tests
                            "skia_use_wuffs=false "  ; missing performance tool
                            "skia_use_system_expat=true " ; use system expat library
+                           "skia_use_system_zlib=true " ; use system zlib library
                            ;; Specify where to locate the includes.
                            "extra_cflags=["
                            (string-join