diff mbox series

[bug#70825,1/2] gnu: Add go-github-com-pion-randutil.

Message ID 7b961cb8f3ef0681862c1843e5928ba1f11a7355.1715111616.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-pion-rtp. | expand

Commit Message

Artyom V. Poptsov May 7, 2024, 7:58 p.m. UTC
* gnu/packages/golang-crypto.scm (go-github-com-pion-randutil): New variable.

Change-Id: Ifb190df843022d556bada7927b180c2518f5869d
---
 gnu/packages/golang-crypto.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 273879b47a..09f9d9f696 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -14,7 +14,7 @@ 
 ;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
 ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
@@ -916,6 +916,28 @@  (define-public go-github-com-operatorfoundation-ed25519
 algorithm.")
       (license license:bsd-3))))
 
+(define-public go-github-com-pion-randutil
+  (package
+    (name "go-github-com-pion-randutil")
+    (version "v0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pion/randutil")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "098isjyvyb8jhrrr57xi45g5m35vb1l92dm5wcy7g2q9x55lvxg5"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/pion/randutil"))
+    (home-page "https://github.com/pion/randutil")
+    (synopsis "Helper library for cryptographic and mathmatical randoms")
+    (description "Helper library for cryptographic and mathmatical randoms.")
+    (license license:expat)))
+
 (define-public go-github-com-protonmail-go-crypto
   (package
     (name "go-github-com-protonmail-go-crypto")