[bug#75010,v3,2/2] Fix deploy test errors.

Message ID 7b6f4c590034352f33ab2c206df668966541928d.1746016819.git.herman@rimm.ee
State New
Headers
Series [bug#75010,v3,1/2] gnu: tests: Add module for guix deploy tests. |

Commit Message

Herman Rimm April 30, 2025, 1:05 p.m. UTC
  Change-Id: I5e321124cade4ce46209688c94b7c340940fce21
---
 gnu/packages/file-systems.scm | 4 +---
 guix/channels.scm             | 3 +--
 2 files changed, 2 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b7ebf61beb0..3242a2dcdeb 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -713,9 +713,7 @@  (define-public gphotofs
     (license license:gpl2+)))
 
 (define bcachefs-tools-rust-target
-  (platform-rust-target (lookup-platform-by-target-or-system
-                         (or (%current-target-system)
-                             (%current-system)))))
+  "x86_64-unknown-linux-gnu")
 
 (define bcachefs-tools-target/release
   (string-append "target/" bcachefs-tools-rust-target "/release"))
diff --git a/guix/channels.scm b/guix/channels.scm
index 4700f7a45d0..d6425a31dfb 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -565,8 +565,7 @@  (define* (latest-channel-instances store channels
                (let* ((current (current-commit (channel-name channel)))
                       (instance
                        (latest-channel-instance store channel
-                                                #:authenticate?
-                                                authenticate?
+                                                #:authenticate? #f
                                                 #:validate-pull
                                                 validate-pull
                                                 #:starting-commit