diff mbox series

[bug#71897,v5,4/6] gnu: Add cppgir-for-telegram-desktop.

Message ID 7b5f9de226a097c8bd929d88250961aabf156431.1720972086.git.i@dan.games
State New
Headers show
Series [bug#71897,v5,1/6] gnu: xdg-desktop-portal: Update to 1.18.4. | expand

Commit Message

dan July 14, 2024, 3:49 p.m. UTC
* gnu/packages/glib.scm (cppgir-for-telegram-desktop): New variable.

Change-Id: Ib9ca3bd376f32d13939adabd2c52e1eb24e2ddcb
---
 gnu/packages/glib.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 3a44207afe..29ac8d5542 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1623,3 +1623,22 @@  (define-public cppgir
 introspection annotations into a set of C++ files defining suitable
 namespaces, classes and other types that together form a C++ binding.")
     (license license:expat)))
+
+;; telegram-desktop requires a more recent version of cppgir
+(define-public cppgir-for-telegram-desktop
+  (let ((commit "9c4f5820d94d62ab451501f016bfea97156518f4")
+        (revision "0"))
+    (package
+      (inherit cppgir)
+      (name "cppgir-for-telegram-desktop")
+      (version (git-version "2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://gitlab.com/mnauw/cppgir")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fa9nf4yljfarihaqj5kd98yysrky7q316mh6l5b1rq39ga15k9b")))))))