diff mbox series

[bug#66689,gnome-team,v2,07/14] gnu: python-pygobject: Update to 3.46.0.

Message ID 7aff4a820d08810315519d9a9abe7f16e2c74053.1698128341.git.vivien@planete-kraus.eu
State New
Headers show
Series Update glib.scm with more low-hanging fruits | expand

Commit Message

Vivien Kraus Oct. 22, 2023, 2:39 p.m. UTC
* gnu/packages/glib.scm (python-pygobject): Update to 3.46.0.
[snippet]: Also remove test_overrides_gdk.py. Update style.
[arguments]: Update style.
[native-inputs]: Same.
---
 gnu/packages/glib.scm | 47 +++++++++++++++++++++----------------------
 1 file changed, 23 insertions(+), 24 deletions(-)

Comments

Liliana Marie Prikler Oct. 24, 2023, 7:46 a.m. UTC | #1
Am Sonntag, dem 22.10.2023 um 16:39 +0200 schrieb Vivien Kraus:
> * gnu/packages/glib.scm (python-pygobject): Update to 3.46.0.
> [snippet]: Also remove test_overrides_gdk.py. Update style.
Should be "Convert to G-Expression" for the style update.
> [arguments]: Update style.
> [native-inputs]: Same.
> ---
As before.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d249188a4f..3812284412 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1007,40 +1007,39 @@  (define glibmm
 (define-public python-pygobject
   (package
     (name "python-pygobject")
-    (version "3.44.1")
+    (version "3.46.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://gnome/sources/pygobject/"
-                           (version-major+minor version)
-                           "/pygobject-" version ".tar.xz"))
+                           (version-major+minor version) "/pygobject-" version
+                           ".tar.xz"))
        (sha256
-        (base32
-         "042pmpyaz7bsbr68znnwdqyhs3j3cajib0k45v1hrs8v6b8has1w"))
+        (base32 "1z6aagb46fhhdd0bb3zk6dfdw3s4y2fva0vv3jpwjj6mvar0hq22"))
        (modules '((guix build utils)))
        (snippet
-        '(begin
-           ;; We disable these tests in a snippet so that they are inherited
-           ;; by the Python 2 variant which is built differently.
-           (with-directory-excursion "tests"
-             ;; FIXME: These tests require Gdk and/or Gtk 4.
-             (for-each delete-file
-                       '("test_atoms.py" "test_overrides_gtk.py"))
-             #t)))))
+        ;; We disable these tests in a snippet so that they are inherited
+        ;; by the Python 2 variant which is built differently.
+        #~(with-directory-excursion "tests"
+            ;; FIXME: These tests require Gdk and/or Gtk 4.
+            (for-each delete-file
+                      '("test_atoms.py" "test_overrides_gtk.py"
+                        "test_overrides_gdk.py"))))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; The default 90 seconds can be too low on slower machines.
-               (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                ;; The default 90 seconds can be too low on slower machines.
+                (invoke "meson" "test" "--timeout-multiplier" "5")))))))
     (native-inputs
-     `(("glib-bin" ,glib "bin")
-       ("pkg-config" ,pkg-config)
-       ("python-pytest" ,python-pytest)
-       ("python-wrapper" ,python-wrapper))) ; For patching shebangs
+     (list `(,glib "bin")
+           pkg-config
+           python-pytest
+           python-wrapper)) ; For patching shebangs
     (inputs
      (list python python-pycairo gobject-introspection))
     (propagated-inputs