[bug#78322,v2,1/3] gnu: Add python-pytest-pylint.

Message ID 7ae34421b9ee0d66100cc2eb11b22ed3eff9aa4a.1746818945.git.sergio.pastorperez@gmail.com
State New
Headers
Series [bug#78322,v2,1/3] gnu: Add python-pytest-pylint. |

Commit Message

Sergio Pastor Pérez May 9, 2025, 7:29 p.m. UTC
  * gnu/packages/check.scm (python-pytest-pylint): New variable.

Change-Id: Iba326a6fc9cbd333eb63edf2ed61dca45cdf2bc9
---
 gnu/packages/python-check.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: 295a35ba20257e965c4eba8488de99fce7bf027f
  

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a0909f6159..8470ba6fa3 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2694,6 +2694,26 @@  (define-public python-pytest-pydocstyle
 @command{pydocstyle}.")
     (license license:expat)))
 
+(define-public python-pytest-pylint
+  (package
+    (name "python-pytest-pylint")
+    (version "0.21.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-pylint" version))
+       (sha256
+        (base32 "0gjm9qy1rsngvli042szqc45y0q5zk1crq28ja01iyjw3n74nxl8"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-pylint))
+    (native-inputs (list python-pytest python-setuptools python-wheel))
+    (home-page "https://github.com/carsongee/pytest-pylint")
+    (synopsis "Pytest plugin to check source code with Pylint")
+    (description
+     "This plugin allows running Pylint with Pytest and have
+configurable rule types (i.e. Convention, Warn, and Error) fail the build.")
+    (license license:expat)))
+
 (define-public python-pytest-qt
   (package
     (name "python-pytest-qt")