[bug#76923,1/2] gnu: apache-arrow: Update to 19.0.1.

Message ID 7ad66fbe16d2e71cf6b6005e019eae257da1992f.1741627853.git.code@greghogan.com
State New
Headers
Series Update apache-arrow. |

Commit Message

Greg Hogan March 10, 2025, 6:06 p.m. UTC
  * gnu/packages/databases.scm (apache-arrow): Update to 19.0.1.
[arguments]<#:configure-flags>: Disable mimalloc allocator.

Change-Id: Ia4e5d99f6f31911683b3ce424604eafa4700d255
---
 gnu/packages/databases.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 84b535eae00..36862030832 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4817,7 +4817,7 @@  (define-public apache-orc
 (define-public apache-arrow
   (package
     (name "apache-arrow")
-    (version "17.0.0")
+    (version "19.0.1")
     (source
      (origin
        (method git-fetch)
@@ -4827,7 +4827,7 @@  (define-public apache-arrow
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "11yzhqdvvcq8k4dhcfnwhc0hl0a2k09gyijln00zbglajk7ihfsk"))))
+         "0l7nc12ykh6b9pcf20mvs4xsk9cyz7a45sdfs08rhilrhd8g10dn"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -4856,6 +4856,9 @@  (define-public apache-arrow
               ;; is unfortunate because jemalloc increases performance:
               ;; https://arrow.apache.org/blog/2018/07/20/jemalloc/.
               "-DARROW_JEMALLOC=OFF"
+              ;; System mimalloc is not suported and must be bundled:
+              ;; https://github.com/apache/arrow/issues/42211.
+              "-DARROW_MIMALLOC=OFF"
 
               ;; The CMake option ARROW_DEPENDENCY_SOURCE is a global
               ;; option that instructs the build system how to resolve