diff mbox series

[bug#70222,v2,02/14] gnu: gwenhywfar: Update to 5.10.2.

Message ID 7aa3bdadb5a2fe754f1b929f75040d61d0ad3942.1714130774.git.flake@uni-koblenz.de
State New
Headers show
Series Updated series to update gnucash to 5.6 / aqbanking 6.5.4 / gwenhywfar 5.10.2 | expand

Commit Message

Julian Flake April 26, 2024, 11:41 a.m. UTC
From: Steve George <steve@futurile.net>

* gnu/packages/gnucash.scm (gwenhywfar): Update to 5.10.2.
[inputs]: add libxml2.
[arguments]: <configure-flags>: Remove flag that's not recognised
--with-openssl-includes; add --with-libxml2-code, --enable-system-certs
and --disable-binreloc

Change-Id: I4085779e3ed7ecb621dd3d0b5427e92962466033
---
 gnu/packages/gnucash.scm | 62 ++++++++++++++++++++--------------------
 1 file changed, 31 insertions(+), 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0f3217ffe3..d8d13f9780 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -242,38 +242,38 @@  (define gnucash-docs
       (license (list license:fdl1.1+ license:gpl3+)))))
 
 (define-public gwenhywfar
-  (package
-    (name "gwenhywfar")
-    (version "5.6.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
-                           "download/364/gwenhywfar-" version ".tar.gz"))
-       (sha256
-        (base32 "1isbj4a7vdgagp3kkvx2pjcjy8lba6kzjr11fmr06aci1694dbsp"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags
-       (list "--disable-network-checks"
-             ;; GTK+3, GTK+2 and QT4 are supported.
-             "--with-guis=gtk3"
-             (string-append "--with-openssl-includes="
-                            (assoc-ref %build-inputs "openssl") "/include")
-             (string-append "--with-openssl-libs="
-                            (assoc-ref %build-inputs "openssl") "/lib"))))
-    (inputs
-     (list libgcrypt gnutls openssl gtk+))
-    (native-inputs
-     (list pkg-config))
-    (home-page "https://www.aquamaniac.de")
-    (synopsis "Utility library for networking and security applications")
-    (description
-     "This package provides a helper library for networking and security
+  (let ((attachid "501")) ;; file attachid changes for each version
+    (package
+      (name "gwenhywfar")
+      (version "5.10.2")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
+                             "download/" attachid "/gwenhywfar-" version ".tar.gz"))
+         (sha256
+          (base32 "1qd950kilf9bcb51b1daykipanml6bg1h3pj10950r98ah1xm9v0"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:configure-flags
+         (list "--disable-network-checks"
+               ;; GTK+3, GTK+2 and QT4 are supported.
+               "--with-guis=gtk3"
+               "--enable-system-certs"
+               "--with-libxml2-code=yes"
+               "--disable-binreloc")))
+      (inputs
+       (list libgcrypt gnutls openssl gtk+ libxml2))
+      (native-inputs
+       (list pkg-config))
+      (home-page "https://www.aquamaniac.de")
+      (synopsis "Utility library for networking and security applications")
+      (description
+       "This package provides a helper library for networking and security
 applications and libraries.  It is used by AqBanking.")
-    ;; The license includes an explicit additional permission to compile and
-    ;; distribute this library with the OpenSSL Toolkit.
-    (license license:lgpl2.1+)))
+      ;; The license includes an explicit additional permission to compile and
+      ;; distribute this library with the OpenSSL Toolkit.
+      (license license:lgpl2.1+))))
 
 (define-public aqbanking
   (package