diff mbox series

[bug#63268] gnu: Add python-goatools.

Message ID 7a9dadbaaecb1eab3d713b921a4d808154ac7f99.1683212209.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#63268] gnu: Add python-goatools. | expand

Commit Message

nafkhamdc May 4, 2023, 2:56 p.m. UTC
* gnu/packages/bioinformatics.scm (python-goatools): New variable.
---
 gnu/packages/bioinformatics.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: f0a51a2bda26f9cc1e0b54b48712bd7cc54408e9

Comments

Ricardo Wurmus May 4, 2023, 5:23 p.m. UTC | #1
Applied with a number of changes.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7db8a91e80..db76d04594 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12337,6 +12337,37 @@  (define-public python-genomic-regions
 using the same syntax.")
     (license license:expat)))
 
+(define-public python-goatools
+  (package
+    (name "python-goatools")
+    (version "1.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "goatools" version))
+              (sha256
+               (base32
+                "1p53h7bnbmi23lcgsajf9vb8vxgjp6lmbz0hl1cx62230jvbfp62"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f))
+    (propagated-inputs (list python-docopt
+                             python-numpy
+                             python-openpyxl
+                             python-pandas
+                             python-pydot
+                             python-requests
+                             python-scipy
+                             python-statsmodels
+                             python-xlsxwriter))
+    (home-page "https://github.com/tanghaibao/goatools")
+    (synopsis "Python scripts to find enrichment of GO terms")
+    (description "Python scripts to find enrichment of GO terms.
+In addition, this package is used for processing the
+obo-formatted file from Gene Ontology website.  The
+data structure is a directed acyclic graph that allows
+easy traversal from leaf to root.")
+    (license license:bsd-3)))
+
 (define-public python-loompy
   (package
     (name "python-loompy")