diff mbox series

[bug#71897,v6,2/7] gnu: xdg-desktop-portal: Update input style.

Message ID 7a857b480ff7c3a055b03a1f780468657b1373b0.1722781401.git.i@dan.games
State New
Headers show
Series gnu: telegram-desktop: Update to 5.3.2. | expand

Commit Message

dan Aug. 4, 2024, 2:30 p.m. UTC
* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update input style.

Change-Id: Iec0630cd945dfcd4db67af30211cbfd4d058766d
---
 gnu/packages/freedesktop.scm | 36 ++++++++++++++++++------------------
 1 file changed, 18 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 99a4469264..d06ce2a48a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3064,25 +3064,25 @@  (define-public xdg-desktop-portal
        (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
     (build-system meson-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib:bin" ,glib "bin")
-       ("gettext" ,gettext-minimal)
-       ("python" ,python)
-       ("python-dbusmock" ,python-dbusmock)
-       ("python-pytest" ,python-pytest)
-       ("python-pytest-xdist" ,python-pytest-xdist)))
+     (list gettext-minimal
+           (list glib "bin")
+           pkg-config
+           python
+           python-dbusmock
+           python-pytest
+           python-pytest-xdist))
     (inputs
-     `(("bubblewrap" ,bubblewrap)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("glib" ,glib)
-       ("flatpak" ,flatpak)
-       ("fontconfig" ,fontconfig)
-       ("json-glib" ,json-glib)
-       ("libportal" ,libportal)
-       ("dbus" ,dbus)
-       ("geoclue" ,geoclue)
-       ("pipewire" ,pipewire)
-       ("fuse" ,fuse)))
+     (list bubblewrap
+           dbus
+           flatpak
+           fontconfig
+           fuse
+           gdk-pixbuf
+           geoclue
+           glib
+           json-glib
+           libportal
+           pipewire))
     (arguments
      `(#:configure-flags
        (list "-Dsystemd=disabled")